Read what our customers are saying about Glass Eye 2000…

“I've been using Glass Eye software since its first release and wouldn't consider using any other software designing program. I use it almost daily, everything from the original design proposal all the way through costing and printout of the final cartoon. It's a wonderful product which only improves with each release. I recommend it every chance I get.”

Christie Wood of Art Glass Ensembles in Denton, Texas

“As a designer for 12 years, I've used many software drawing programs (Photoshop, Illustrator, and more). All of them involve a rather difficult learning curve to become proficient in their use. Glass Eye 2000 is easy to install and so intuitive to use that I was able to begin a project within ten minutes after installation. Among many things, I find the Properties function is especially helpful regarding materials usage, construction cost and pricing. Thank you for a wonderful software package. Now, all I have to do is add my imagination. You've thought of everything else!”

Katherine Bell of Bell Graphics in Jacksonville, Florida

“Glass Eye 2000 is an answer to all prayers. Being able to do patterns and to match glass on a pattern sure makes things quite a snap. The incremental upgrades that have come about install-with-ease and the new glass samples are really good. Stained glass always seemed to be quite a chore until I happened upon this program and it was well worth the money to invest in. Keep up the outstanding work!”

Mike Kline of Mike Kline's Stained Glass Studio in Clifton, Colorado
"I've been using the Glass Eye software for three years now, and about six months ago upgraded to Glass Eye 2000. It was well worth it, especially the enhanced glass representations from the glass manufacturers' images. I converted one of my old patterns and was just in awe with the way my design sprang to life. I find this feature really helpful when showing clients/students what their project will eventually look like. It gives them the opportunity to grasp what a difference the selection of colour makes. Besides designing custom work, I also teach stained glass. Your software has been **invaluable** in helping me develop patterns for beginners. I save a lot of time using the Add Background feature, which allows me to trace an existing picture quickly and then modify it to match the student's competence/confidence level. Being able to resize patterns or parts thereof is also a BIG plus, as are the programme's costing options. You have a great software product which is **easy to learn** and use, backed up by reliable, **friendly and fast customer service**. What a nice and all too rare combination!"

Jackie MacDonald of L'Artisan Glass Works & Decor in Ontario, Canada

"After I first discovered Glass Eye 2000, I downloaded the trial version. Within minutes I had drawn a simple flower. Within an hour I had drawn several images and made my buy decision. It was the **greatest drawing tool I had ever used**. I had tried MacDraw, Corel Draw (which is what I was using before), CAD II, and even AutoCAD. In comparison, Glass Eye 2000 was **simple** and intuitive. It allowed me to focus on my design, not the mechanics of drawing. My hat is off to you on this one. You have done a superb job of defining and executing the features in this CAD package. My answer to other artists is now simple: don't even think about it. Just buy the Glass Eye 2000 and GO!"

Joseph Bremmer in Lomita, California
“I've been doing the tutorial for a couple of hours now and I'm blown away. This is probably one of the most user-friendly, best-written and most well thought-out tutorials I've ever used. I appreciate the way that you write as though you're sitting here talking with me. I don't feel intimidated, and I don't feel insulted. That's pretty cool. I wish you guys could write the tutorials for Photoshop and Illustrator (smile). Whoever engineers your tutorials is obviously a real ‘person's person’! I can barely wait to get done with the tutorial so can start designing my own windows. Thus far, I believe that you folks have thought of every possible problem and solution. Thanks for your time and efforts. I have no doubt that this program is going to greatly increase my profit margin. Thanks for such a great program.”

Pam Biagi of Glass Impressions in Kennesaw, Georgia

∞

“I have the Professional Edition and can't believe how much this software has helped in my design work. I find it very user friendly, an exceptionally fun and useful tool for creating designs in a short period of time with instant results thanks to all the different effects. It's exciting to watch my designs come alive when the glass colors and textures are added. I wonder how I ever got along without it. What used to take me days is now done in a few hours. One of the nicest features (of the many) is once my drawing is complete and I add the color and glass texture I am able to present to my client a very professional looking presentation. Another big big plus is that if any changes are to be made they are done in minutes. You truly do make a quality and useful program for us stained glass people. Keep up the good work.”

Jerry Waier of Pinehaven Stained Glass in Two Rivers, Wisconsin
"I have used your software for several years in my studio. It is without peer in stained glass software. I started out using it without reading the tutorial and it is really easy to learn and is very user friendly. I have really enjoyed your newly released Glass Eye 2000. It makes presenting a design look very professional, since now you can add the glass colors and textures from the main glass vendors. I feel this is one product no glass studio should be without!! It cuts pattern making time way down and resizing or changing colors in a design is a snap. Thank you for your product and keep up the good work."

Nancy Weiss of Twin Lakes Art Glass in Rockwell City, Iowa

"Glass Eye 2000 is an indispensable part of my business! As the owner of a studio that does only commissioned work, the 'see before you buy' feature has enabled me to nearly double my annual sales. Also, time between initial customer consultation and a signed contract has been substantially reduced. With the use of my laptop and a digital projector, my customers and I can explore glass alternative selections almost instantly. Furthermore, the use of a projector enables the customer to see an accurate rendition of the final product in its intended location. This capability worked particularly well during the design stages of two church commissions currently in progress."

Dimitri P. Gruszka of Prism Effects in King George, Virginia

"This has got to be one of the most fun programs I have ever used. It has opened up a world of talents I never knew I had."

Reb Blower in Venice, Florida
Copyright

Copyright © 2001–2007 Dragonfly Software. All rights reserved.
Nineteenth printing, January 2007

We have worked hard to create a quality product and wish to realize the fair fruits of our labor. We therefore insist that you honor our copyright. At the same time, we want to encourage the use of our product in all possible circumstances and will try to meet your needs if you will call and ask us for permission.

The following terms govern your use of the enclosed Software unless you have a separate written agreement with Dragonfly Software.

License Grant

Dragonfly Software grants you a license to use one copy of this Software on any one computer for each license issued. ‘You’ means the company, entity, or person whose funds are used to pay the license fee. ‘Use’ means storing, loading, installing, executing, or displaying the Software. If multiple different workstations will access the Software through a network, each workstation must have its own license, regardless of whether the Software is used at different times or concurrently.

License Use

It is your responsibility to protect your license from loss or corruption due to malfunction, upgrade, or replacement of the computer or its individual components upon which the Software has been licensed. Dragonfly Software provides utilities within the Software for preserving or transferring your license prior to changes to your computer or its components. Dragonfly Software reserves the right to charge a relicense fee if it determines that any of these conditions apply: (a) you have not taken proper precautions to protect your license with the utilities provided, (b) you have installed your license on a computer or its components with known malfunctions, (c) you fail to take reasonable and appropriate precautions to guard your computer or components against common conditions that cause a disruption in function, such as inadequate virus and worm protection, exposure to lightning damage, etc., or (d) you request more than one reissue of your license in any twelve (12) month period.

Ownership

The Software is owned and copyrighted by Dragonfly Software. Your license confers no title or ownership in the Software and should not be construed as a sale of any right in the Software.

Copies and Adaptations

You may make copies or adaptations of the Software only for archival purposes. You must reproduce all copyright notices in the original Software on all authorized copies or adaptations. You may not make the Software available over the Internet nor copy it onto any bulletin board or similar system. No part of this Software or auxiliary files may be reproduced, stored in a retrieval system, or transmitted in any form or any means electronic or mechanical, including photocopying and recording, for any purpose other than the purchaser’s personal use without the written permission of Dragonfly Software.
Use of Designs
You may construct and sell artworks based on the designs included with this Software. You may not, however, sell, give away, or transfer any designs in printed or digital format, whether modified or unchanged.

Use of Glass Library
All glass images and their corresponding descriptive data distributed with the Software are included with the permission of the glass manufacturers. These images and data have been optimized and edited by Dragonfly Software for use with the Software. You may not use these images and data except in conjunction with this Software.

Other Restrictions
You may not modify, adapt, translate, create derivative works, decompile, disassemble, or otherwise reverse engineer or attempt to reverse engineer or derive source code from, all or any portion of the Software or anything incorporated therein or permit or encourage any third party to do so.

Transfer
Your license will automatically terminate upon any transfer of the Software to another individual or company. Upon transfer, you must deliver the original and all complete, partial, or electronically stored copies of the Software and related documentation to the transferee. The transferee must accept these Terms as a condition to the transfer. If the Software is an update, any transfer must include the update and all prior revisions. Any additional license for this Software sold to you at a discount by Dragonfly Software cannot be resold or transferred unless the sale or transfer includes your primary license.

Termination
Dragonfly Software may terminate your license upon notice for failure to comply with any of these Terms. Upon termination, you must immediately destroy the Software together with all copies, adaptations, and merged portions in any form.

Export Requirements
You may not export or re-export the Software or any copy or adaptation in violation of any applicable laws or regulations.

Disclaimer of Warranty
This software and the accompanying files are sold “as is” and without warranties as to performance of merchantability or any other warranties whether expressed or implied. Because of the various hardware and software environments into which the Software may be put, no warranty of fitness for a particular purpose is offered.

Good data processing procedure dictates that any program be thoroughly tested with non-critical data before relying on it. The user must assume the entire risk of using the Software. Any liability of the seller will be limited exclusively to product replacement or refund of purchase price.

Trademarks
Dragonfly Software, the Dragonfly Software logo, and Glass Eye 2000 are trademarks or registered trademarks of Dragonfly Software in the USA and other countries. Microsoft and Windows are registered trademarks of Microsoft Corporation.
## CONTENTS

I. Introduction ............................................................... 1  
II. Contacting Us ........................................................... 7  
III. Overview ...................................................................... 9  
IV. Tutorial ...................................................................... 15  
   Lesson 1: A Quick Tour ................................................... 15  
   Lesson 2: Looking Closer ................................................ 21  
   Lesson 3: Viewing a Design ............................................. 30  
   Lesson 4: Changing the Triangle ....................................... 36  
   Lesson 5: Your First Design ............................................. 41  
   Lesson 6: The Shortcut Menu and Quick Figures ............... 46  
   Lesson 7: Adding and Deleting Knots .............................. 54  
   Lesson 8: The “Suggest” Command ................................... 58  
   Lesson 9: Color ........................................................... 63  
   Lesson 10: Text and Piece Labels .................................... 74  
   Lesson 11: Design Properties and Browsing ....................... 78  
   Lesson 12: Importing and Exporting ................................. 85  
   Lesson 13: Crosshairs and Grid Lines ............................... 93  
   Lesson 14: Cut, Copy, and Paste ...................................... 99  
   Lesson 15: Advanced Lines ............................................ 101  
   Lesson 16: Moving and Resizing ..................................... 109  
   Lesson 17: Flip, Reflect, and Repeat ................................. 116  
   Lesson 18: Lamp Wizard and More .................................. 123  
   Lesson 19: Multiple Designs and Views ............................ 129  
   Lesson 20: Putting It All Together .................................... 133  

• Glass Eye 2000 User’s Guide •
V. Command Summary ............................................. 143
VI. Keyboard Commands ......................................... 163
VII. HSL & RGB ............................................................ 165
VIII. Glossary ............................................................... 169
IX. Index ........................................................................ 173
Acknowledgments

Dragonfly Software is indebted to the following contributors and supporters: Shelly Berg, Marie-Hélène Bourbeau, Mark Jon Madison Isíás de los Cobos, Luca Griziotti, Martha Hanson, Guy Hubble, Petra Hütter, Mark Mabry, Fernando Maseda, Ken McDonald, Jeff Vail, Mary Wilk, and all of our beta testers.
I. INTRODUCTION

Welcome

Glass Eye 2000 is software to help hobbyists and professionals design stained glass windows. It is a tool for creating patterns with beautiful design lines and glass. Its purpose is like that of a word processor, except that instead of helping to create documents it helps you to create designs.

Skeptics may wonder if computerizing an art form results in better art. We reply that programs like this are not intended to replace the artistic process but are here to give the artist one more tool for producing art. Word processors do not stifle the writing process as long as one's focus is on the writing and not the computer.

You are soon to discover that the designs you create with Glass Eye 2000 are more malleable than any paper-and-pencil design. Imagine being able to resize your design to any dimensions. Or to see, in an instant, the effects of different glass textures or lead widths. Or to move a lead line and have all connecting lines readjust accordingly to maintain their connections. All this is possible here, and by spending less time erasing, redrawing, aligning, and copying you can spend more time on the art of design.

Glass Eye 2000 was created by people with a love for the art of stained glass and a devotion to quality software. We hope that with this program your stained glass designs are more fun to create and are more beautiful than ever before.
Minimum system requirements

Microsoft Windows 98, or any later version of Windows
32MB RAM
64MB Free Disk Space

Glass Eye 2000 will also run on a Mac with Virtual PC, Boot Camp or Parallels (with Windows installed).

Installation

1. Insert the CD into your CD ROM drive.
2. If installation does not begin automatically, run D:\SETUP.EXE (where D: is the letter of your CD ROM drive).
3. The Setup program will guide you through the installation process. Follow the instructions on the screen.

If you have previously installed another version of Glass Eye 2000, such as a downloaded trial version, you do not need to uninstall it before installing your new one.

From time to time we make product updates available to you at no charge. See Lesson 8 in this User’s Guide for information on keeping your software up to date.

Should it ever become necessary to remove Glass Eye 2000 from your computer, follow these steps:

1. Open the Windows Control Panel.
2. Double-click the Add/Remove Programs icon.
3. Select “Glass Eye 2000” from the list of software.
4. Click the Change/Remove button.
5. Follow the instructions on the screen.
### Product registration

Each computer running Glass Eye 2000 must have a product license. A license is activated using a 40-digit license key. There are two ways to get one:

1. You receive a license key at the time of purchase.
2. You receive a registration number with your CD. You then use this number to obtain a license key. This is typically handled automatically using your Internet connection.

Glass Eye 2000 will prompt you for your license key or registration number, so you need only follow the directions. You have 30 days from the first time the software is run to complete the licensing. Please contact us if you have any difficulties activating your product license or if you wish to purchase multiple licenses.

### Parking and transferring your license

You can park and retrieve your product license on the Dragonfly Software server using the "Park License" and "Retrieve License" commands. This is an easy way to maintain your license while you make major system changes to your computer or when you move from one computer to another. If you don’t have Internet access on both computers, use the "Transfer License" command. Consult the Help system for details on these features.

### Lost license

If substantial changes to your computer should cause the loss of your product license, contact us by email and we will do what we can to restore you. For more information on preserving your license during major system changes, please read the "License Key Care" topic in your Glass Eye 2000 help system.
A choice of editions

Glass Eye 2000 comes in four editions, allowing you to choose the level of functionality that’s right for you. To move from one edition to a higher one, use the “Upgrade…” command on the Registration menu.

Standard Edition

The Standard Edition contains the essential design tools for drawing, coloring, and numbering. It’s adequate for the hobbyist, but professionals and serious amateurs will want one of the more complete editions.

Professional Edition

These features are added by the Professional Edition:

- Glass library of over 2600 glass samples from nine manufacturers
- Text in unlimited fonts and colors
- More import/export file types, including GIF, TIFF, PNG, and PCX; DXF export; variable image resolution
- Assign names and prices to glass and textured colors
- Piece numbering by both color and location; manual piece numbering
- Lamp Wizard—a 3D modeling tool for panel lamps
- Measurements shown either as decimal numbers or as fractions
- Print with a scale factor
- Export, print, and get materials usage on selected design elements
- Assign “global” color codes that apply across designs, not only to individual designs
- Auto-orientation setting that automatically chooses portrait or landscape printing, whichever uses paper more efficiently
- U-came borders
- Repeat command to make multiple copies of a design element
- Printer calibration tool to compensate for inaccuracies in your printer or printer driver
- Align piece labels with glass direction
Professional Plus Edition

These features are added by the Professional Plus Edition:

- AutoTrace Background—automatically convert a scanned or imported line drawing into a Glass Eye 2000 design
- AutoTrace Text—automatically convert your text into lines so that letters can be filled with color, rotated, etc.
- Change the position and rotation of glass images in your designs
- Transparency controls so that background images can be seen through the glass in your designs
- File importing from programs like Adobe Illustrator, CorelDraw, and AutoCAD.
- Display measurements such as height, width, radius, and angle during drawing operations
- Keyboard entry of locations and sizes during drawing operations

Enterprise Edition

The Enterprise Edition supports plotting and cutting devices. This edition contains all product features, including:

- Explode command bursts your design into its constituent pieces
- Piece Picker mode makes moving or rotating pieces easy
- Send your design to your plotter or cutter
- Offset command for drawing interior or exterior offsets of shapes
- Export to DXF and DWG formats with text output and additional exporting options
Patterns for sale

Glass Eye 2000 comes with a library of 400 patterns. If that's not enough for you, we have additional patterns for sale on our website. Just visit www.dfly.com and click on the "patterns for sale" link. We have hundreds of patterns in Glass Eye 2000 format ready for use. Or use Glass Eye 2000 to customize these patterns to your heart's content.
II. CONTACTING US

- **Postal address**
  Dragonfly Software
  1158 North Fairview Avenue
  Goleta CA 93117
  USA

- **Telephone**
  (831) 438–3200
  Monday to Friday, 9am–5pm Pacific Time

- **Fax**
  (888) 463-8817

- **Electronic mail**
  support@dfly.com

- **Web site**
  http://www.dfly.com
Technical support

Our extensive product documentation can provide instant answers to your support questions:

- Use the options available on the Help menu within Glass Eye 2000, or simply press the F1 key.

- Consult the lessons within this User’s Guide, or use the index on the last few pages.

If these resources do not answer your question, contact us directly. The best way to submit a question is to visit:

www.dfly.com/help

There you will find answers to common questions and also be able to ask other questions and receive a reply via email. If you wish to submit your question via email, write to:

support@dfly.com

If your question would be of general interest, visit our online discussion group. There you’ll find hundreds of users with interests similar to yours. Read Lesson 8 within this User’s Guide for more information.
III. OVERVIEW

Glass Eye 2000 is a computer-aided design (CAD) program created specifically for the design of stained glass windows. Because stained glass window design is different from other types of design, Glass Eye 2000 has features not found in other CAD or illustration programs you may have used.

You create a Glass Eye design by drawing a pattern and then choosing glass colors for the pieces defined by the lines of that pattern. The following overview will introduce you to the process. For now we won't worry about which commands to use—let's just understand the design process in general.

A stained glass pattern is typically composed of graceful curves, straight lines, circles, and ellipses (stretched circles). We'll look first at drawing curves. It is not immediately obvious how you might draw a curve using your mouse. If you were to define a curve using mouse movement you would almost certainly end up with a very jagged, uneven line. Computers are excellent at calculating smooth curves, however, so we'll let the computer do most of the work!

Knots and curves

We define the shape of a curve by placing a series of points on the screen. These points are known as knots. As knots are placed the computer will produce a smooth line going through those knots. For example, if we lay out the following knots:

1
2
3
4
The computer can fit a smooth curve through them, as follows:

![Image of a curve with knots labeled 1 to 4]

Changing the shape of a curve is done by moving the knots and letting the computer refit the knots with another smooth curve. For example, moving knot #3 to the left could give this result:

![Image of a curve with knots labeled 1 to 4 after moving knot 3]

- **Sliders**

It is very common to have one line begin or end somewhere along the length of another line. On the next page you'll see we have added a second line that terminates in the middle of our first line.
Our intent here is clearly for the new line to connect with the original line. If, for example, we now moved knot #3 upward, we would want to see the connection maintained:

Notice how the endpoint of the new line has moved to keep its connection to the first line. As the example shows, there are two types of knots on a line. The first are those that define the shape of the line. The others are sliders, which move with a line as the shape of that line changes. Sliders appear as white dots while fixed knots appear as gray dots. Notice how when the knot was moved most other knots on that line remained fixed in place, whereas the slider traveled with the moving line.
■ Straight lines

Let's now add a straight line between two existing knots. A straight line is no different from the other lines we have drawn so far—any line defined by only two knots will be straight. Here's our design with a straight line added:

■ Pieces

We now have an enclosed region, which is called a piece. Any piece can be colored. For simplicity we'll fill using a solid color:
You would naturally want the piece to follow any changes to the design, so if knot #2 were moved upward the piece would change shape in the obvious way:

![Diagram](image)

It is helpful to think of a stained glass design as something like a spider's web. A web is a collection of lines that are interrelated. As you tug on one strand of the web, other strands shrink or stretch to maintain their connections. Glass Eye 2000 has been designed to help you build a web of lines that is malleable and beautiful.

This, in a nutshell, describes the approach you will use to design windows with Glass Eye 2000. Of course, there is much more to talk about: circles and ellipses, glass, lead widths, resizing, scanning, etc. You also need to know the specific Glass Eye 2000 commands. The best way to learn all this is to begin the tutorial.
IV. TUTORIAL

Lesson 1: A Quick Tour

This lesson introduces you to the essential features of Glass Eye 2000 in just a few steps. You’ll learn how to:

- Start the program
- Choose a design
- Resize a design
- Print a design
- Exit

To start Glass Eye 2000, double-click the shortcut item on your desktop.

Another way to start the program is as follows:

1. Click the button on the Windows taskbar.
2. Choose from the menu that appears.
3. Choose from the next menu that appears.
4. Choose from the next menu that appears.
For this lesson, ignore any text or design you might see on the screen after Glass Eye 2000 starts. If a box appears asking you to register the product, you may do so now or just click the Cancel button.

## Opening a file

We begin by looking at one of the designs in our pattern library. Each design is stored in a single file. This is the Open button. Click on it to bring up the Open dialog box, shown below.

![Open dialog box](image)

This dialog box shows you that you are currently looking at Glass Eye files in the folder called Glass Eye 2000. There is only one such file in this folder, which is the one containing the Welcome message. There are also seven sub-folders.

Double-click on the folder named "Dragonfly designs" and you'll see a collection of folders named for the artists and publishers that have supplied us with patterns. Next, double-click on the folder named "CKE Publications" to see the list of designs from that publisher.
This folder contains a collection of Glass Eye designs. You can be sure these are Glass Eye designs because the file names are preceded by the icon.

Double-click the word "Barnaby" to open that file. If you installed Glass Eye 2000 from a CD then you should see glass samples within the pattern. If you installed after downloading the software from our web site, you'll see solid colors only because you do not yet have the full glass library.

- **Resizing a design**

You can use the Resize command to set the precise width and height of your design. Try this now by choosing "Resize All" from the Modify menu.
In the dialog box that appears you can set the exact width and height of the design. Try this now by entering a width of 10 inches. Because the "Maintain proportions" box is checked, the height is automatically adjusted proportionally. (By unchecking this box you can set width and height independently.) For now, leave the "Anchor" control unchanged. After you click the OK button your design will be resized to the new dimensions. Because the design is now much smaller than before, it fills only a fraction of the view. To enlarge its appearance, choose "Zoom All" from the View menu. The widths of the lines are not affected by the resizing, so you might find that the lines now appear too thick. Let’s ignore this issue for now. We will discuss how to change lead size in Lesson 5.

■ Page Setup

The design is now the size we want, so let’s print it. Before we do, make sure the printer is properly configured. Choose "Page Setup" from the File menu. When the Page Setup dialog box appears, choose the format "Actual size" and be sure the "Show border" option is checked. Choose the orientation "Portrait" and then click the OK button.

■ Printing

To print this design, click the Print toolbar button or choose "Print" from the File menu. When the Print dialog box appears, click the OK button to print your entire design.

■ Assembling

By choosing a format of "Actual size" in the Page Setup dialog box you will get an actual size printout. The program will print efficiently to any printer properly configured in Windows, so if the design fits on the paper accepted by your printer then it will appear on a single sheet. Unfortunately, few users will have printers large enough to print a big design on a single sheet of paper. The only solution is to use tiling, which prints to several sheets that you assemble into a full-sized design. On the next page are the steps.
Step 1: Print showing borders
You have already completed this step by printing your design at actual size with the borders showing. Most likely this required four sheets of paper.

Step 2: Trim off margins
Cut off along the border with scissors or a paper cutter. Notice that you do not need to cut along all borders of every page. At most you need to cut along two borders, as the diagram shows.
Step 3: Overlap pages
Assemble the trimmed pages to form the complete design. You can attach the pages with transparent tape, or you can spray mount the pages to a cardboard backing.

You should now have a custom-sized image of "Barnaby" on paper.

Exiting Glass Eye 2000
Exit the program now in the way common to all Windows programs: click the "X" box in the top right corner of the main window. Other ways to exit are to press Alt+F4 or to choose "Exit" from the File menu. When asked if you wish to save your changes to the design, click "No."
Lesson 2: Looking Closer

The remaining lessons will look at features of Glass Eye 2000 in greater detail. In this lesson we’ll examine some of the details we glossed over in Lesson 1. In particular, we’ll look closely at:

- The program’s display
- How to set measurement units and display precision
- Printing options, including page setup and print preview

We’ll also introduce you to our Help system.

When the program starts for the first time, your screen looks something like this:

![Welcome to Glass Eye 2000!]

Welcome to Glass Eye 2000!

The best way to get started is to read the tutorial, found on the Help menu as well as in the printed User’s Guide.

You might prefer to view our collection of hundreds of patterns by choosing "Browse Designs" from the File menu. Or double click one of the buttons at the left to see the glass library.

To order this software, choose "Purchase Glass Eye 2000" from the Registration menu.

Be sure to visit Dragonfly Software at http://www.ddfly.com for the latest news and information.
If you have completed Lesson 1 you are likely to see the "Barnaby" design on your screen. This is because the program automatically loads whatever design was last worked on by a previous user.

This is a standard Windows application. At the top is a title bar showing the name of the program ("Glass Eye 2000"). Below that is the menu bar, which gives access to nearly all commands. Below the menu bar is the toolbar, which gives quick access to the most common commands. At the left is the color palette, which you will use to define the colors in your stained glass window. The large area in the center is the view, which is where designs appear. Just below and also to the right of the view are scroll bars that allow you to move your view up, down, right, and left. And at the very bottom is the status bar, which displays helpful textual information, including the horizontal and vertical position of the mouse pointer.

■ Sizing the main window

In the top right corner of Glass Eye 2000 you will see a triplet of buttons. (There is a second triplet below it, but consider only the top triplet for now.) The triplet will appear in one of two ways:

- or

Here is the meaning of each of these buttons:

- Reduce (minimize) the window to a button on the Windows taskbar
- Enlarge (maximize) the window to fill the desktop
- Restore the window to its previous size
- Close the window.
You will probably have best results if Glass Eye 2000 fills your entire desktop. If you see the maximize button in the middle of the triplet, then click on it to make the main window as large as possible. If you do not see the button, your window is already maximized.

- **The toolbar**

The buttons on the toolbar are of two types. The first type of buttons show you the mode that you are in. The mode represents your current activity. There is a mode for changing colors, another for zooming in or out, etc.

For example, here you see the Pick toolbar button. This button currently appears pressed in, telling you that you are in Pick mode. In this mode you can select the lines of a pattern and change their shape.

The other type of toolbar buttons are property buttons. These buttons show you what properties are set for the current view of your design. You will be introduced to view properties in Lesson 3.

You can find out what each button does by resting the pointer over it for about a second (without moving the pointer or clicking the mouse). The name of the button will appear in a little box called a tool tip. When the tool tip appears, you can also read a longer description of the button down in the status bar. Try it now by resting the pointer over the Pick button. If you forget which toolbar button accomplishes a desired function, just move the pointer across the toolbar, pausing at each button, until you see the name of the button you want.

- **Units and Precision**

You can work in five different units of measure: inches, feet, millimeters, centimeters, and meters. Because these lessons are designed to work in units of inches and feet, you’ll probably want to choose those units.
Choose "Units and Precision" from the View menu. The dialog box that you see at the right will appear. Set the first "Units" control to Inches, but use Feet for the other units. Set all "Display format" controls to Decimals. "Decimal precision" determines how measurements are rounded when displayed. Choose 0.01 in every case indicating that measurement values are rounded to the nearest 1/100". Check the "Show units" box so that a symbol for your choice of units appears on the rulers and the status bar. Make sure the precision values at the bottom are both set to 1°.

Click the OK button when the options are properly set.

**Page Setup**

In Lesson 1 you used the "Page Setup" command on the File menu to specify printing options. This command provides you with a variety of options for how your design looks when printed:

**Format**

- **All on one page**: Print the design as large as possible on a single sheet.
- **Actual size**: Print the design at its actual size, even if this means spanning several sheets of paper.
- **Scale by**: Print at actual size, but changed by the given scale factor.
When printing actual size or to scale, you have the options of printing a border around the usable area of each sheet and, putting page numbers on sheets, and showing the scale factor on sheets.
Show title and artist / Show date and time / Show filename

Enable these options if you want the corresponding information to appear on the printed pages.

Reverse design

This prints a mirror image of your design. Use this option if you want to print a view of your design from the rear instead of the front.

Paper

Size: Letter, Legal, Envelope, etc.
Source: Manual Paper feed, Sheet Feeder, Tractor feed, etc.

Your choices here depend on the type of printer you have. Don’t change these settings unless you are sure that you must.

Orientation

Portrait or Landscape, depending upon whether you want the short or long edge of the paper at the top of the page. Checking the Auto option will choose whichever orientation uses the fewest pages. The page count is shown in the top left corner.

Margins

The size of the margins determines the border area of each page.

Printer…

Select a different printer or change printer properties.

Calibrate…

This invokes Printer Calibration, which allows you to compensate for printer inaccuracies caused by the printer hardware itself or by problems with your printer driver.
■ Print Preview

Before printing a design, you can see what the design will look like on paper using Print Preview. Confirming that your design will print the way you want it to can avoid the waste of a faulty printout. Click the Print Preview toolbar button now, or choose "Print Preview" from the File menu. You should see one or two pages showing you how the design will print. Click the "Next Page" button a few times to view the pages. Click "Close" to exit Print Preview.

■ Printing

Choosing "Print" from the File menu, or clicking the Print toolbar button, brings up the Print dialog box.

![Print dialog box]

28 • Glass Eye 2000 User's Guide •
Use this dialog box to choose the printer, a range of pages, and the number of copies. (Number of copies and collation options will be unavailable if not supported by your printer driver.) If you were to click the "Properties" button you would bring up another dialog box that gives you extra control over your printed output, such as graphics resolution and color adjustment. The properties you see will depend on the type of printer you have installed.

**The Help system**

We conclude this lesson with an introduction to the Help system. The easiest way to get Help is to press the F1 key. This brings up a Help window, which looks like this:

---

### Glass Eye 2000 Help

Glass Eye 2000 comes with an extensive Help system ready to answer your questions. It follows modern Windows software conventions, so you probably already know how to use it. If not, just keep reading.

The help viewer displays tabs in the navigation pane to the left of this text. Here's how they work:

<table>
<thead>
<tr>
<th>Tab</th>
<th>What it does</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contents</td>
<td>Displays help books and pages. Click a book and it expands to show groups of pages. Click a page to view its corresponding help topic.</td>
</tr>
<tr>
<td>Index</td>
<td>Provides a list of keywords. Click a keyword to view its corresponding topic. If several topics reference the same keyword, select the topic to view from a popup menu.</td>
</tr>
<tr>
<td>Search</td>
<td>Enter words or phrases to scan topic content and find all topics that match the search criteria.</td>
</tr>
<tr>
<td>Favorites</td>
<td>Creates personalized lists of favorite help topics. Quickly go to topics you view often by selecting them from this tab.</td>
</tr>
<tr>
<td>Glossary</td>
<td>Displays an alphabetized list of terms relevant to information in the help system. Select a term to view its corresponding definition.</td>
</tr>
</tbody>
</table>

Choose one of these tabs to begin searching for the help you need.
Click the **Contents** tab to find topics grouped by subject.
Click the **Index** tab to find specific topics listed alphabetically.
Click the **Search** tab to find the topics containing a specific word or phrase.
Click the **Favorites** tab to bookmark an interesting topic.
Click the **Glossary** tab to read definitions for terms used in Glass Eye 2000.

Experiment with the Help system now. After you click the tab you want, follow the instructions on your screen. For example, you might want to try to find the list of answers to common user questions by clicking the Index tab and then double-clicking "common questions." When you are ready to continue, click outside of the Help Topics window to dismiss it.

### "What’s This?"

You can get help on a specific feature by using the "What’s This?" command. Try it now by clicking the toolbar button shown at the left. This puts you in "What’s This?" mode, signified by the pointer appearing as an arrow and a question mark together. Now choose any menu item as if you were selecting it for use. A help screen will appear describing the use of that menu item. After you read the description, dismiss the help window.

You can similarly get help on anything you see on the screen. Enter "What’s This?" mode again, and this time click on a toolbar button. As before, the help window for that feature appears. You can try this on the color palette, the scroll bars, the status bar, the view, etc.

Lastly, "What’s This?" will give you help on keyboard functions. Enter "What’s This?" mode, and then press a key that has been defined for use within Glass Eye 2000. For example, try pressing the F5 key while in "What’s This?" mode to find out what it does.
Lesson 3: Viewing a Design

This lesson will show you a few of the different ways you can view a design. You'll learn about:

- Scrolling and zooming
- Showing lines as hairlines
- Turning rulers, knots, and colors on and off

■ Opening the "Triangle" design

Let's open a file containing just about the simplest stained glass window imaginable: a triangle. Use the Open command as you did in Lesson 1 and look in the Tutorial folder. Depending on what design is currently showing, you might have to navigate over to this folder. For example, if you had the "Barnaby" design on your screen then you're probably now seeing the contents of the "CKE Publications" folder. To return to the base Glass Eye 2000 folder you'll first have to twice click the "Up One Level" icon as shown:
Once you've navigated to the base Glass Eye 2000 folder, you'll see this:

Open

Look in: Glass Eye 2000

Bevels
Dragonfly designs
Welcome. eye
Glass
HTML
My designs
Textures

File name: 
Files of type: Glass Eye Files (*.eye) 
Open

Enable preview

Open the Tutorial folder by double-clicking it.

Open

Look in: Tutorial

Flag. eye
Suggest. eye
Triangle. eye

File name: 
Files of type: Glass Eye Files (*.eye) 
Open

Enable preview

Double-click on the word "Triangle" to open that file. Your view should now hold a simple triangular pattern.
Don’t be troubled by the simplicity of this design. We could use a more realistic design, but that would only add unnecessary complexity. Let’s keep things simple while you learn.

Before we discuss how to change the design, let’s experiment with the different ways this design can be viewed.

### Scrolling

Scrolling allows you to choose which part of your design is visible in the view. You can scroll the view by dragging either of the scroll boxes to the right and to the bottom of the view. (To "drag" means to move the mouse while keeping the left mouse button held down.) Try dragging the scroll boxes now.

You can also scroll by clicking in the area on either side of a scroll box, or by clicking on any of the scroll arrows. Play with these features on both scroll bars until you feel comfortable with them.

Another way to scroll the view is to use the Pan button, shown here. Click this button now. Notice that after you do this the Pan button has popped in and the Pick button has popped out; notice also that the pointer changes to a shape corresponding to the image on the button. These changes let you know that you are now in Pan mode. Without holding down any mouse buttons, move the pointer to anywhere in the view. Now hold down the left mouse button and drag the pointer around the screen. The view will scroll as you move the mouse.
Zooming

Zooming allows you to increase or decrease the size of the image in the view. The quickest way to zoom is to use your keyboard: press either the "+" key to Zoom In or the "-" key to Zoom Out. Give them both a try now. There is even a Zoom All key: Enter. No matter what scroll position or zoom factor your view currently has, pressing the Enter key will always restore you to a full view of your design.

For more precise zooming, you can enter Zoom mode by clicking this toolbar button. Try it now. The pointer changes to the magnifying glass shape signifying Zoom mode. You can now click anywhere in the view and two things happen: the location you clicked on moves to the center of the view and the view is zoomed in. Try clicking with the right mouse button and the same thing happens except that you zoom out instead of in.

For even greater zoom control, while in Zoom mode you can make a zoom box (a rectangle) around the part of the image you want to fill the view. To try this, position the pointer over the top-left knot of the triangle. Press down the left mouse button, then while holding down the button move the pointer to the middle of the triangle; notice the zoom box as you drag. Now release the button. You should now see only the part of the triangle that appeared within the zoom box before you released the button. You can repeat this process a few times to zoom in more, although after a few zooms no further zooming will be allowed.

If you have a mouse with a wheel, rolling the wheel will normally scroll your view vertically. If you’d like the mouse wheel to control zooming, you can set this behavior using the Units and Precision command you saw in Lesson 2.

Now press Enter to return to a full view of the design, and click the Pick toolbar button to return to Pick mode. Your pointer should once again look like an arrow.
View properties

In addition to changing the size and position of the view of a design, you can change the way the design is drawn simply by clicking toolbar buttons. The need for some of these options might be unclear at first, but as you begin designing you are sure to find them all useful.

Understand that there is a difference between changing the view of a design and changing the design itself. All the changes we're making here affect only the way we see the triangle; the design itself isn't changing. This is similar to changing the way you take a photograph. You can change the camera lens, the lighting, or the film type. All of these change the view (the photograph) of the person, but the person remains unchanged.

Let's look at the most useful view properties.

• Show Hairlines

This is the Show Hairlines button. Click it now. The lines of the triangle are now shown as very thin lines, and the button should look pressed in to let you know you have Show Hairlines enabled.

With all view property buttons, a "pressed in" button means that feature is enabled, and a "popped out" button means that feature is disabled.

If you click on the button again you will pop the button out, causing Show Hairlines to be disabled. Try clicking on the button a few times and see how the triangle changes. Leave Show Hairlines disabled before continuing.

• Show Rulers

The next option is Show Rulers. Clicking the button will reveal a horizontal and a vertical ruler. Looking at the rulers, you can tell that the triangle measures 5" wide and 4" high. You might want to scroll or pan the window now to see how the ruler responds. Notice that
there are marks on the ruler that show you the exact location of your pointer. Also notice the pointer location shown numerically at the rightmost end of the status bar.

Find the point in the view that measures 0" on both the horizontal and vertical rulers. This point is called the ruler origin. You can change the origin to any location you like. Try this now by choosing "Set Ruler Origin" on the View menu, and then clicking anywhere in the view. Notice that the location you clicked on has become the new ruler origin.

Now disable Show Rulers.

- **Show Knots**

  Next is the Show Knots button. The button is probably in the down position, so click on it to bring it up. You should notice that knots are no longer visible. The main purpose of this option is to allow you to view your design in a more natural, uncluttered state than when knots are shown. Of course, it is harder to change the shape of a curve when you don't know where the knots are!

  Click the Show Knots button again to turn that feature back on.

- **Show Colors**

  You can turn piece color on and off using the Show Colors button. Turning off color lets you concentrate on the pattern itself, rather than on the colors of the glass. Also, it takes time for the computer to display glass, so hiding colors when you don't need them will speed up the time to draw a design on the screen.

  Click the Show Colors button again to turn that feature back on.

You can now exit Glass Eye 2000, or continue on to the next lesson.
Lesson 4: Changing the Triangle

In this lesson you will learn how to reshape a design by moving its knots and lines. You’ll also be introduced to the undo and redo operations. Finally, you’ll learn how to use the color palette and how to recolor a piece.

If the Triangle design is not currently open, please open it now just as you did in Lesson 3.

Press Enter to cause a Zoom All, and then press the "—" key twice to provide some working room around the triangle. You might want to remember this as you proceed through the lessons: after opening any file (or after doing a Zoom All) press the "—" key once or twice and it will often be easier to manipulate the design.

Make sure that you are in Pick mode (the Pick toolbar button should be in). Also make sure that Show Knots and Show Colors are enabled and that Show Hairlines is disabled.

- Dragging and selecting

Changing the shape of the triangle is easy. Move the pointer over one of the knots, press down the left mouse button, and then drag the mouse. When the knot is moved to the place you want, release the button. During the move you will notice that the lines to move become thin and that the adjacent colors disappear. This is because most computers are not fast enough to show thick lines and areas of color as quickly as you can move the mouse. (If your knot did not move, you probably need to position the pointer over it more exactly.)
Sometimes you want to move something other than one knot. You might want
to move several knots, an entire line, or any combination of these. To move
more than a single knot you must first select the things you want to move and
then drag that selection across the screen.

Try this by clicking on the middle of any of the three lines of the triangle. (Do
not hold the mouse key down for long: just click and let go.) The line will
change color, indicating that it has been selected. Now drag the line around
the screen and release it at some new position. Now click on another line.
Notice how the first line you selected is now unselected and that only the
new line is selected. Drag around the newly selected line. When you have
experimented enough, click outside of the triangle to unselect any lines that
were selected.

■ The Ctrl key

You can select more than one line by using the Ctrl key. Click on some lines
again, but this time hold down the Ctrl key as you do so. Now selecting a
line does not unselect a previously selected line. Click on a selected line while
holding down the Ctrl key to unselect that line. When you have exactly two
lines selected, try dragging them around the screen.

■ The select box

If you wish to select a large number of lines, you may find the select box
useful. Let’s select all three of the lines using this method. At some point
above and to the left of the triangle, press down the left mouse button and
drag the mouse. You will drag out a box, and when you release the mouse
button every line wholly within that box will be selected. Drag out a box large
enough to select the entire triangle, and then drag the entire triangle to another
place in the view.

Now click in the view away from the triangle to unselect all lines.
■ The Shift key

Often you want to move a selection only horizontally, vertically, or diagonally. If you hold down the Shift key while dragging, your movement will be restricted to only the eight directions shown.

Try dragging some part of the triangle around the screen while you hold down the Shift key to get a feel for this feature. You can actually specify directions different from the eight shown, but we'll save that for Lesson 6.

■ Nudging

If you want to move a selection straight up, down, left, or right, you can "nudge" it by using the arrow keys. Try this now. Select a knot or a line by clicking on it, then press one of the arrow keys. The selection will move a small amount in the direction you indicate.

For fine control, hold down the Ctrl key while you press an arrow key. This time your selection will move only a very slight amount.

If nudging does not work, you might be using the part of the keyboard that combines arrow keys with the numeric keypad. If so, turn off Num Lock on your keyboard and try again.

■ Deleting

There are many things you can do to a selected shape besides moving it. Another operation you can do is to delete it. Let's try deleting lines from the triangle. Select one of the lines and then press the Del or Delete key. (You can choose "Delete" from the Edit menu if you prefer.) The line disappears, and the color of the triangle disappears with it. This makes sense, because
only areas bounded by lines can be colored. Continue to delete lines until the entire triangle is gone.

If pressing the Del key does not delete anything, you might be using the Del key on the numeric keypad. If so, turn off Num Lock on your keyboard and try again.

### Undo and Redo

The triangle is gone, but we can recover it. Nearly every operation in Glass Eye 2000 is undoable! All you need to do is click the Undo button, shown at the left. Click the Undo button until the triangle is restored. Each click of the Undo button takes you back one operation, so if you deleted the lines of the triangle one at a time then this should take three clicks.

If you undo an operation by mistake you can "Undo the Undo," which is called a "Redo." A Redo reverses the effect of a previous Undo. Try it now by clicking the Redo button, which is just to the right of the Undo button. Go ahead and Undo and Redo a few times to get a feel for these operations. Stop at some point where the entire triangle is once again visible. Having Undo and Redo available to you should make you more confident to experiment when you use Glass Eye 2000: you know that most anything you do can be undone!

### Erasing

There is another way to removing lines that you might prefer to using the Delete command. Click the Erase button, shown at the left, to put you in Erase mode. Now hold down the left mouse button while you position the pointer near one of the lines. Try this until the entire triangle is gone, then use Undo to restore it.
Coloring

Changing the color within the triangle is easy using the **color palette**. The color palette, at the left of the screen, should look something like what you see here. The length of the palette depends on the size of your main window, and you might even find your last button only partially showing.

The first button is always blank, and is used for removing color. The remaining colors can change from pattern to pattern, depending on what colors the designer used. You will learn how to change palette colors in Lesson 9.

The button that is pressed in indicates the **working color**. (In the palette shown here, the second button down holds the working color.) The working color is the color you "paint" with as you assign color to pieces.

Choose any color to be the working color by clicking one of the color buttons now. Notice that the pointer changes to a paint can shape indicating that you have entered Color mode. The paint can is upright when there is nothing to color at its location, so that is how the pointer will appear when outside the triangle. The inside of the triangle is colorable, so when the pointer is there you will see a tipped paint can. Click inside and the working color will fill the triangle.

Close this design now by choosing "Close" from the File menu. When asked "Save changes to Triangle?" click the "No" button; otherwise, you would be permanently changing the design used in this tutorial, which you do not want to do.
Lesson 5: Your First Design

In this lesson you’ll create a design of your own. You’ll learn how to draw curves and how to set values for both the face width and the heart thickness. Lastly, you’ll learn how to save your design.

Now we’ll create a design from scratch. To the right is what it will look like when completed. It’s a mushroom, or perhaps an umbrella. Yes, we’re still keeping things simple!

To start a new design, click the New button. (You can also choose “New” from the File menu or simply press Ctrl+N.) You now have a blank design, which you will add to during this lesson. This is like getting out a blank sheet of paper on which to write a new story.

- Lead size

A line section is the part of a line that goes between two of its knots. Each line section in your drawing has a face width, which is the width of the visible lead in your window. Each line section also has a heart thickness, which is the width of the lead that sits directly between pieces of glass. Looking at the cross-section of a typical "H" came helps to make this clearer. For each line section you can make these widths whatever you like. You can even view and print your design showing the lead width, the heart thickness, or both, depending on your needs.
Before we begin drawing we will set the face width and the heart thickness for our lead lines. Choose "Default Line Properties" from the Modify menu:

![Default Line Properties dialog box]

For face width there are eleven choices from solid and dashed hairlines (the thinnest) to 1/2" (the thickest), and all but the first two can be changed to whatever values you wish by typing a measurement directly into one of the
boxes. Heart thickness values work similarly. You can change your line color to any of six preset colors, or by double-clicking one of the custom colors you can make lines any color you wish.

Pick a face width of 3/16" and a heart thickness of 1/16", then click the OK button. Now every lead line we draw will be this size until we change the default size to something else.

**Drawing the curves**

Before you start drawing, make sure you have the "Sticky" property on. The button looks like a shoe stepping on chewing gum. (If you are using a low-resolution display you might not see this button. Use the "Sticky" option in the View Properties command instead.) Recall that a property is active if the button looks pressed in. You want to have the Sticky property on as it ensures that lines will stick together automatically. You should turn this property off only in unusual circumstances.

To draw curves you need to be in Curve mode, so click the toolbar button shown here. The pointer changes to the shape of a pen, letting you know that you are ready to draw. Let's draw the straight, horizontal line first. At a point just left of the center of the view, click the mouse. (Remember that to "click" means to press the left mouse button down and quickly let go; do not "drag" the mouse.) Now move the pointer around the screen. A thin straight line will be drawn from the place you clicked to the pointer, showing you the shape of the line you are creating. Move the pointer to the right of the center of the view and **double-click** there. The double-click signifies that you are finished drawing that line. The line will now be drawn in at its proper thickness.

If you don't like double-clicking, there is another way to terminate drawing. At the place you want to end the line do a normal, single click. After this, click the right mouse button and choose "Accept" from the shortcut menu. It doesn't matter if you move the mouse between those last two clicks. (The
"Drawing Properties" command that you'll see in the next lesson lets you skip this menu if you wish.)

The horizontal line is complete. It's fine if the line is not perfectly horizontal. Now add the curved top. Click on the knot at the leftmost end of the horizontal line. Move the mouse somewhere above the center of the horizontal line and click again. Finish the top line by double-clicking on the knot at the rightmost end of the horizontal line.

Now add the stem by clicking on the middle of the horizontal line and then drawing a vertical line down. If you make any mistakes in this process, just click Undo and try again.

Having the Sticky property on made it easy to draw this figure. Notice how the knots of the horizontal line are shared by the beginning and ending knots of the curved line. And notice how the knot in the middle of the horizontal line sits directly on that line.

Switch to Pick mode and drag the rightmost knot around the screen, but don't distort the figure too much or you will end up with a mess! Notice how the figure hangs together. These are not just three lines but three **connected** lines. Having the Sticky property enabled tells Glass Eye 2000 to make these connections automatically.

Notice especially the behavior of the slider. Recall from the Overview that a slider is a knot that attaches to a line but does not affect the shape of that line. The slider in your figure is the white knot in the middle of the horizontal line. (Knots that are not sliders are gray.) That knot became a slider because you placed it in the middle of an existing line. Watch how the slider follows the horizontal line during movement.

Disable Show Knots and then color the body of the mushroom just as you colored the triangle in Lesson 4. The mushroom should now look more or less like the picture at the beginning of this lesson.

Put yourself back in Pick mode before you continue.
Let's see how the design looks with a thicker lead. Select all lines using a select box, or by pressing Ctrl+A, or by choosing "Select All" from the Edit menu. Now choose "Line Properties" from the Modify menu. Select a face width of 1/2" and then click OK.

If you like, experiment with changing the face width of just one line section. Or try using Undo and Redo to switch between different face widths to see how they compare.

### Printing your design

You can print your design at any time by using the Print command, just as you did in Lessons 1 and 2. If you would like to print only a portion of your design, just select that portion before you use the Print command. (Note that the capability to print only a portion of your design is not available in the Standard Edition.)

### Saving your design

Saving to disk in Glass Eye 2000 works exactly as in every other Windows application, so we will give only a quick description here. The easiest way to save your design to a file is to click the Save button now. Because you have not yet named your design, the Save As dialog box will appear. At the top of the dialog box you will see a folder name to the right of the words "Save in". You want to save your work in the Tutorial folder, and if the name "Tutorial" appears here then all is well. If not, it should appear in the list of folders beneath this field and you will first need to double-click on the Tutorial folder where you see it. In the field labeled "File name" type "Mushroom" and then press Enter. Your design is now saved to disk under that name. You can now exit Glass Eye 2000 or continue on to the next lesson.
Lesson 6: The Shortcut Menu and Quick Figures

In this lesson you'll learn to use the shortcut menu, and you'll see how it will help with drawing rectangles, squares, ellipses, and circles. You'll also learn about drawing polygons and the options on the Drawing Properties dialog box. Lastly, you'll learn how to customize the shortcut menu to the way you work.

Begin this lesson by clicking the New button to start a new design, just as you did to begin your mushroom design.

The shortcut menu

Common in Windows programs is a menu called the shortcut menu. This is nothing more than a menu that appears when you click the right mouse button. The items on the menu will change depending upon the circumstances under which you bring up the menu.

Click the right mouse button now and you will see the menu shown here. This is the current shortcut menu, giving you a choice of four items (with others unavailable because there is no design). We are not interested in any of these options, so left-click outside the menu to remove it. In the remainder of this lesson we will bring up other shortcut menus that will interest us more.
Quick rectangles and squares

A rectangle can be drawn by connecting four straight lines. This requires a fair bit of work, and it's difficult to get the alignment perfect. Fortunately, there is a command just for drawing rectangles. There are actually two ways to draw a rectangle:

1. Pick the center and one of the corners.
2. Pick two opposing corners.

Let's give both of these a try. There is no toolbar button for rectangle drawing, so choose "Rectangle" from the Draw menu. Before you begin drawing, click the right mouse button. Because you are now in Rectangle mode, you will see a different shortcut menu than before. This menu lets you choose your method for drawing rectangles. The bullet symbol tells you which method is currently in use. In this example, the "Center, Dimensions" method is being used. On your menu, click on the "Center, Dimensions" item to choose this method.

Now click (left mouse button) somewhere in the view to begin drawing your rectangle. Remember to release the button; don't do a drag. Move the mouse to another part of the view. You will see a rectangle with its center where you first clicked and with one corner at the pointer. Click a second time to complete the rectangle draw.

There is nothing new about the rectangle you have just drawn. It is nothing more than four curves connected at the knots. Enter Pick mode, drag one of the corners, and you will see that the lines are not constrained to be arranged as a rectangle.
Notice that you defined the rectangle by clicking, not dragging, the mouse, which was also true when you drew the curves for the mushroom. You might keep this rule in mind:

**In Glass Eye 2000,**

*all line creation is done using clicking, not dragging.*

Try drawing a few more rectangles until you feel comfortable with the process.

Click the right mouse button to bring up the shortcut menu again. This time choose "Corner, Dimensions" and then draw a few more rectangles. This time you'll see that the first point you click becomes one corner of the rectangle and the other point becomes the opposing corner.

Now choose "Square" from the Draw menu and try drawing some squares. Experiment with changing the square drawing method by using the shortcut menu. If you run out of room on the screen, just scroll the view.

### Show Measurements and Keyboard Entry

At the top of the shortcut menu are two options, one called Show Measurements and the other called Keyboard Entry. These options are available with the Professional Plus and higher editions and also during the trial period, but even with a Standard or Professional Edition you'll be able to use these features in a limited way. If you get warning messages having to do with licensing, just click the Proceed button.

Choose "Square" from the Draw menu and click the right mouse button to display the shortcut menu. Select "Show Measurements" and start drawing your square. This time while you draw you'll see an indicator showing you the width of the square. You'll get similar feedback when drawing other shapes.
Click the right mouse button again and this time choose "Keyboard Entry". A dialog will appear, looking something like this.

Here you can enter the location and size of the square using the keyboard so that you can get precisely the shape you want. The tabs at the top of the dialog let you choose between entering the location of the center of the square or the location of one of its corners.

For access to these functions without using a mouse click, keyboard shortcuts are available. For drawing measurements press the spacebar, and for keyboard entry press the Enter key. Escape means to cancel, as usual. You must have already started to draw your shape for these keys to work.

Quick ellipses and circles

Now that you are familiar with drawing rectangles and squares, experiment in the same way with ellipses and circles. The process is the same: choose "Ellipse" or "Circle" from the Draw menu, and bring up the shortcut menu to choose the drawing method. Try drawing several of each using both drawing methods.
Drawing Properties

Another way to access the drawing methods is to use the Drawing Properties command on the Draw menu. Choose the feature now to see a dialog box like the one below. You'll see the currently selected drawing methods for squares, rectangles, circles, and ellipses.

Notice that you can set an option to have the shapes you draw formed into groups. With this setting, selecting any line of the shape causes all lines of the shape to be selected. We'll discuss groups more in Lesson 18. For now, be sure this option is not selected because future lessons assume that the shapes you draw are not automatically grouped.
Earlier in this lesson we discussed the shortcut menu that appears when you click the right mouse button while drawing. If you don’t want a shortcut menu but would prefer to have a right mouse click cancel the current drawing operation, you can indicate that preference here. You can also elect to remove the Help item from the menu.

The controls in the bottom right of this dialog box allow you to choose your own. Shift key locking directions, used when drawing and moving lines. (Review Lesson 4 if you need to be refreshed on that topic.) We won’t discuss this feature now, but you can experiment if you wish. Click the Help button if you would like more information.

## Polygons

In the middle of the Drawing Properties dialog box is a control for choosing the number of sides when you draw a polygon. Make sure the number of sides equals six and then click OK. Now choose Polygon from the Draw menu to enter polygon mode. Polygons have only one method of drawing: a click at the center and then a click at a corner. Using this technique, create a few hexagons in your design. If you like, return to Drawing Properties, select another value, and draw polygons of a different shape.

## Customizing shortcut menus and hot keys

Glass Eye 2000 allows you to create your own shortcut menus, and also lets you assign hot keys to your favorite commands. Let’s try this now. Start by choosing “Customize Menus and Hot Keys” from the View menu.

There are two main shortcut menus in Glass Eye 2000: one for when there is nothing currently selected in the design and one for when there is a selection. You can configure these two menus independently to provide different choices based on this context. Note that some choices make sense only when there is a selection and you will not be able to add these to the “nothing selected” menu.
The dialog has three panes that you use to build the menus. The center pane contains all of the commands available in Glass Eye 2000 as well as a horizontal line that you can use to group and organize the commands. Resting the cursor momentarily on a command in this list will display a brief description of the command's function. The two side panes display the current organization of the "nothing selected" and "something selected" shortcut menus.

To add an item to one of the menus, highlight the item in the command list by clicking on it, and then click the top arrow button pointing to the menu where you want it to be added. By default the item will be inserted at the bottom of the menu. If an item is currently highlighted in the menu you are adding to, the new item will be inserted directly below it. Only the horizontal line can be added more than once to either menu.

To remove an item from a menu, highlight it and then click the corresponding arrow pointing back to the list of commands.

You can modify the top-to-bottom order of items in either menu by highlighting the item you wish to move and then clicking the adjacent up or down arrow buttons.
You may also define a "hot key" for any command. While highlighting a command in the command list, press the key that you want associated with that command. You'll then be able to invoke that command while working on a design just by clicking that key; no Ctrl or Alt key sequence is required. To delete a hot key, press the Delete key while highlighting a command in the command list.

After you've experimented with this feature, click the "Cancel" button.

We do not want to keep any of the work done in this lesson, so choose "Close" from the File menu and click "No" when asked if you want to save.
Lesson 7: Adding and Deleting Knots

In this lesson you’ll learn how to add knots to a line using the Add Knot and Subdivide commands. You’ll learn to remove knots by selecting and deleting them.

A general rule for drawing lines is this:

The fewer knots on the line, the smoother the line.
The more knots on the line, the more control you have over its shape.

Begin this lesson by clicking the New button to start a new design.

Adding and deleting knots from a line couldn’t be easier. Let’s experiment on a new line. Draw a curve that looks something like this.

Now click on the Add Knot toolbar button. The pointer changes to a shape to indicate that you are in Add Knot mode. Place the tip of the arrow somewhere in the middle of the right line section and click.
Now enter Pick mode and drag the new knot to another location. Dragging it downwards, you might get this.

Let’s delete the knot you just added. Click on the knot to select it, then press the Del key. (Clicking the Cut toolbar button, or choosing “Cut” or “Delete” from the Edit menu, will do the same thing as pressing the Del key.) The line is now restored to the shape it had before you added the knot.

**Subdivide**

We will now make the design that appears to the right. Before we get started, use the “Drawing Properties” command (discussed in the previous lesson) and make sure that the “Make each shape a group” option is turned off.

Draw the border first. Choose “Square” from the Draw menu and draw a square on your screen not too close to the curve you just created. Recall that the square will be created as four connected curves.

Instead of immediately drawing the three other lines, which would be hard to do precisely, let’s first position the other knots. We want the knots to be evenly spaced along each side. Notice that the top and bottom lines are divided into two equal sections and the side lines are divided into three equal sections.

Enter Pick mode and select both the top and bottom lines; remember to hold down the Ctrl key as you click on the second line. Choose “Subdivide” from the shortcut menu to bring up the Subdivide Sections dialog box.
You want to divide each of these lines into two sections, so accept the number 2 in the dialog box by clicking OK. The square should now look like the first figure below.

Select the left and right side lines and do the same, except divide them into three sections each by entering 3 in the Subdivide dialog box. It is now easy to draw the remaining lines precisely. Click the Curve toolbar button and draw them as shown above.

**Intersecting lines**

One problem with the figure you just created is that you can’t color it. The reason is that the new lines you added do not intersect one another; they overlap. Imagine building a window by overlapping lead came instead of soldering sections together!
What we need are two "weld" points in the center of the design. This is easily done using the Add Knot command we introduced at the beginning of this lesson. Get into Add Knot mode again and click (with the tip of the arrow) on each intersection point.

You should now have knots at both intersection points as shown in the middle diagram above. Now color the pieces with whatever colors are currently available on your color palette.

We do not want to keep any of this work, so choose "Close" from the File menu and click "No" when asked if you want to save.
Lesson 8: The "Suggest" Command

Glass Eye 2000 lets you change the shape of a design as much as you please. If you distort a design too greatly, it might become impossible to color some of the pieces. This lesson will introduce a command that will help you identify and fix such problems. We'll also discuss how to make sure you're running the latest version of Glass Eye 2000.

Open the file "Suggest" in the Tutorial folder. It looks like this:

It seems that you should be able to color each of these figures with one or more colors. Try now to do so. You will find that only the last figure can be colored! What is wrong?

The problem is that the first three figures are badly formed in some way, even though they look reasonable at first inspection. Fortunately, there is "Suggest" command that analyzes your designs, reports such problems, and gives you suggestions on how to solve them.

Let's examine each of these figures in turn to see what the problems are. The Suggest command analyzes whatever is visible in the current view, so to receive suggestions on only one figure you should first zoom in on that figure to make it the only one visible. Do this now. Put yourself in Zoom mode and drag a zoom box around the circle. The circle should now be the only figure visible; if not, zoom or pan until it is.
Now pick "Suggest" from the Help menu. If you're running Glass Eye 2000 version 1.2 or later, you will see the dialog box pictured to the right. Verify that all boxes are checked and click "Continue."

If this dialog box did not appear then just continue with this lesson, but be sure to read the section on upgrading your software at the end of this lesson.

The next message you see will be the one shown to the left. Coming out from this message is a line pointing to the knot that is causing the problem. What this message is telling you is that a knot is very near to a line but is not attached to it, which is likely to be trouble. If you look closely you should see that the line is pointing at two knots very close to each other, and this is the cause of the problem.

Click on "Next" to see further messages. You should see the same message, but this time the line will be pointing at the other of the two adjacent knots.

Click on "Next" again. You will be told that no further problems are found. Click the OK button to dismiss the dialog box.
By now you can be sure that something is wrong with those two adjacent knots. Let’s investigate.

First, click the Show Hairlines toolbar button to enable that viewing option. Doing so will make the problem easier for you to see. Now zoom in closely on those two adjacent knots.

You can see that there is a gap in the circle, which is why it could not be colored. You can now enter Pick mode and drag one knot on top of the other to reconnect the circle. After you do so, zoom out until you can see the whole circle. You should now be able to fill the circle with color.

Disable hairlines (by clicking that toolbar button again) and this time zoom in on the square until it fills the screen; you might be able to do this by scrolling horizontally. We will now find the problem with this figure by choosing "Suggest" from the Help menu once again. You will see the suggestion shown here.

This is the same problem we experienced in the Lesson 7: two lines cross but they do not intersect at a knot. This problem is easily solved as before by entering Add Knot mode and placing a knot at the intersection of the two lines. After doing so, you should be able to fill each of the four pieces with color.

Now zoom in on the triangle. Ask for suggestions and you should receive three, including an "Overlapping Lines" suggestion.
The problem here is that the top of the triangle, which looks like a single line with four knots, is actually two overlapping lines. You can see what is happening by clicking on (selecting) one of the top line sections of the triangle. The figure (shown in the top figure below with the right line raised a bit to make the point) is not a valid piece because the top two lines are not connected.

Click on "Next" or "OK" until there are no more messages. You will see two "Knot Unattached to Line" messages because these suggestions also apply to this figure, but the "Overlapping Lines" message identifies this problem best.

One way to solve the problem is to follow the advice of the suggestion and to delete one of the lines. Let's delete the right line to get the figure shown here.

Now enter Pick mode and drag the right end of the remaining top line over to the right to complete the triangle. You will now be able to color it.

Finally, zoom in on the last figure, which looks something like a figure eight. You are able to color each of the circles without difficulty. Try asking for suggestions now, and you will be given a "Missing Knot" suggestion. If you like, show hairlines and zoom in closely where the circles touch and you will
see that there is indeed a place where the two lines cross. But this crossing did not cause problems when coloring, so you can ignore this suggestion. The point of this final example is that the suggestions you receive are just that: suggestions. There are times when you might well choose to ignore them.

If you have lines for which you do not want to see suggestions, select those lines and use the Line Properties command. There you’ll see an option to exclude those lines from consideration.

Close the current design without saving it.

■ Do you have the latest version?

As part of our service to you, Dragonfly Software will provide updates to Glass Eye 2000 from time to time. We intend to send out email when these are available, but you can also check for these yourself by using the “Do I Have the Latest Version?” command on the Help menu. Just make sure your Internet connection is established and then follow the directions.

Another way to stay informed is to join our discussion group. There you can meet other users of Glass Eye 2000, ask questions, and share designs. To join, visit:

http://groups.yahoo.com/group/glasseye

After you’ve joined, use the “Visit the Discussion Group” command on the Help menu any time you want to visit the group.
Lesson 9: Color

In this lesson you will learn the tools for adding color to your designs. By "color" we mean both ordinary solid colors as well as images of glass. You'll learn how to search for colors, how to apply textures to colors, how to color a piece, and how to change the color of several pieces at once. You'll also learn about various options for displaying color in designs.

Open the "Flag" file in the Tutorial folder. This is a design composed of eight pieces in three colors. In Lesson 4 we discussed how to use the color palette to make a color the "working color" and how to change the color of a piece. Let's look at the basic coloring commands in more detail.

■ Entering color mode

Clicking on a color button puts you in Color mode. You can also use the Color toolbar button, shown at the left, to enter Color mode. In color mode you can click on pieces to give them the working color.

■ Removing color

At the top of the color palette is a blank button you can use to remove color. Click that button now to select "color removal" as the working color. Now click within the star and watch its color vanish.

■ Changing several color regions at once

You know how to change the color of one piece, but let's say you want to change all the red pieces in the flag to blue. After making blue the working
color you could click on each of the four red pieces, but a faster way is simply to click on one red piece with the right mouse button. Using the right mouse button means “change the color of this piece, and any other piece of the same color, to the working color.” Try this by clicking the blue color button and then clicking with the right mouse button on any red piece. All red pieces will change to blue.

After a color change can be a good time to use the Undo and Redo operations. By going back and forth between two alternative colorings using Undo and Redo you can judge which coloring you like best. Click Undo a few times until the flag is restored to its original colors.

Another way to change the color of several pieces is to drag a color box around the pieces you want to color. Try this now. Click on one of the color buttons, then drag a box around the entire flag. Watch all pieces change to the working color. Click Undo to restore the original colors.

- Changing the color of a color button

The colors now on the color palette are only a few of the millions of available colors. You select new colors by double-clicking one of the color buttons, or you can use a right button click if you prefer. This tells the computer that you want to change the color on that button.

Try this now by double-clicking the color button that currently looks blue. When you do so, the Color Selector dialog box appears. The easiest way to pick a color using this dialog box is to click in the spectrum control (the large, rainbow-hued square) and then to click in the luminance bar (the thin rectangle to the right of the spectrum control) to adjust brightness. Clicking higher in the luminance bar makes the color brighter; clicking lower makes it darker. Your color appears in the box in the bottom-left corner.

Use the dialog box to choose a deep shade of purple. Also try dragging (instead of clicking) the mouse pointer in the color controls. After you make
your spectrum control and luminance bar choices your dialog box might look like this:

![Color Selector](image)

Notice that the name of the color appears under the color box. When you have the new color showing, click OK. The button that was once blue is now purple. Purple is also now the working color.

Use your new color by clicking in the star, turning it purple.

### Applying texture

Every color can have a texture applied to it. Let's see this in operation now. Double-click the purple color button to bring up the Color Selector again. Use the texture control to choose "Wispy" as your texture. You should now see an image of a purple wispy glass where before there was a solid purple.

Click OK to close the dialog box. Purple wispy is now on the button and is also the working color. Click on the star to see that color in your design.
Glass

The availability of glass images from glass manufacturers is one of the most exciting features of Glass Eye 2000. This feature is active in the Professional and higher editions only.

Begin by double-clicking the red color button. Doing so will bring up the Color Selector with the "Textured Color" tab selected with red as the current color. Now switch to the glass page by clicking the "Glass" tab at the top. The Color Selector will now look something like this:

The nine red squares represent the nine glass samples that best match the red on the Textured Color page. (The samples shown here are from an extensive glass library. If you downloaded the trial version from our web site you will see
a different set of glass because your library is much smaller.) The best match is in the top-left corner, then next best is to its right, and so on. The entire glass library has been sorted this way, and to see the rest you only have to scroll using the control to the right of the squares.

Have some fun experimenting with this unique way of selecting glass. Click on the Textured Color tab and select a color, then click on the Glass tab to see the entire glass library sorted according to how well samples match the color.

At the bottom of each glass sample is text that indicates the manufacturer and part name of the sample. The first character is the first letter of the manufacturer name, then after a dot is the part name of the glass. For example, K·41SPL is shorthand for Kokomo 41SPL. By clicking on a glass sample it becomes highlighted, and then you can learn more by examining the right-hand side of the Color Selector. In the current example, we can see that the selected sample is streaky glass with the description "Ruby Red, Clear."

You can filter the list even further to help you find the glass that best suits your needs. Each name in the list of manufacturers can be turned on or off, so you can see glass from only those that interest you. Below that list is an area where you can enter keywords. Each word you enter there is compared against the part name, the category, and the description of every sample. Only if all the keywords match is that sample included. The "Show favorites only" control allows you to see only your favorite glass, and later in this lesson you’ll learn how to mark a sample as a favorite.

■ **Color codes and prices**

The Professional and higher editions allow you to assign a color code and a price to any color. We’ll skip these for now, but we’ll come back to color codes in Lesson 10 when we talk about piece labeling and to prices in Lesson 11 when we talk about design properties.
Zooming in on glass

Have you noticed the "Zoom" button to the left of the description? Highlight any glass sample (for example, Armstrong 81DS) and then click on that button. A close-up view of the glass sample will appear:

Here you have access to a few functions that are not seen on the Color Selector. The first one is the ability to specify the measured size of the sample. This measurement is important, as it tells Glass Eye 2000 the correct magnification level for the glass texture when it appears in your design. The figure above shows that the glass pictured measures twelve inches across. These values are provided by the manufacturer and you should not change them unless you know them to be wrong. If you add any glass samples of your own, be sure to check this value so that your glass appears correctly when used. (Read the Help topic "Adding Glass and Textures" for instructions on how to add your own samples to the glass library.)

Try marking the sample as a favorite and then clicking OK to see how that affects the images shown in the Color Selector. There you can check the "Show favorites only" box to filter the list of glass samples to show only your favorites.
The "Rotate 90°" does just what you think it does, and you're welcome to experiment with it now.

"Direction" refers to the flow of the appearance of the glass. For example, Armstrong 81D5 appears to flow left to right, so it has a horizontal direction. If you feel that a glass image has a direction different from the one indicated then you are welcome to change it. The direction property affects several Glass Eye 2000 operations; for example, piece labels can be aligned with glass direction.

The slider changes the opacity level associated with the image. All images start with a 50% opacity, which in Glass Eye 2000 simply means a normal opacity level. You can change this value if you know that a particular glass has a higher or lower opacity. Once you move your mouse pointer near the slider you'll see the glass image rendered transparently, with the opacity value in back of it to give you an idea of how something behind the glass will show through. Later in this lesson you'll see how glass opacity can affect the appearance of your design.

You can use the "Delete" button if you know that you will never need this sample. Let's not experiment with that now.

Click the "Cancel" button to return to the Color Selector.

To gain quick access to some of the functions just described, do a right-click on any of the glass samples. The menu pictured to the right will appear. Try this now and mark one of the samples as a favorite. Of course, if it is already marked as a favorite then the menu choice will read "Unmark as Favorite."

You can select a glass color either by double-clicking the sample or by highlighting the sample and then clicking the OK button. Select any one of the samples now. You'll see the sample appear on the color button where the solid red used to be. It is now the working color, so you can now right-click
on one of the red stripes in the flag to turn all the solid red stripes to red stripes that look like real glass.

- Color Options

The glass samples in our library come directly from the manufacturers and they range in width from 2" to 24". When a glass image is smaller than a piece in your design, the image is repeated as many times as necessary. You might have noticed that when you placed glass within the flag the image was repeated, but this depends on the size of the glass sample you selected.

The border lines between adjacent images often distract from the beauty of a design. One way to reduce the visibility of these borders is to flip every other image so the joining of two images becomes a reflection. If you want to eliminate the repetitions entirely you can choose to have each glass image stretched to fit each piece exactly. This has the disadvantage of ignoring the actual size of the glass texture, but it can be preferable in some circumstances.

The Color Options command allows you to choose from among these rendering methods. Choose "Color Options" from the View menu now. Try switching between the "stretch" option and the "actual size" option to see how the appearance of your design changes. When rendering at "actual size" try reflecting the images to see how that looks. There is even the option of using a solid color approximation, which can be useful when you want to get a sense of the color but not be distracted by the texture.
While we're here, experiment with other options on this dialog box. You can display a second color palette if you need more colors than will fit on a single palette. There is also a button to limit the colors that appear on your palette to only those that actually appear in your design.

The "highlight" option at the bottom causes the border of a piece to be highlighted when the mouse is placed within it. Turn on this feature, click the OK button, and move the mouse on top of the flag. You must be in color mode (or manual numbering mode, which we'll hear about in Lesson 10) to see the highlighting.

We'll try out the Opaque/Transparent slider in a separate exercise later in this lesson.

Make sure your glass rendering is at actual size, then close the Color Options dialog.

- Setting the working color to a color in the design

Instead of always choosing the working color by clicking a color button, while in Color mode you can choose the working color by holding down the Shift key and clicking within a piece. The cursor will change to an eyedropper shape when you do this. Try this now by clicking on one of the white pieces while holding down the Shift key. White is now the working color. Notice how the white color button appears pressed in.

- Changing the color of a button to the working color

The working color can easily be placed onto any button on the color palette. Just hold down the Shift key and click a color button.

It is not often that you need to place the working color on a button, but there is one situation where it comes in very handy. Let’s go through it now using the color button showing purple wispy glass. Double-click that button, choose a different color, and click OK. Now you no longer have purple wispy glass
on the button, but the color is not lost because you do have it as the color of the star. To get purple wispy glass back on a color button, hold down the Shift key and click within the star, making its color the working color. Now with the Shift key still down, click a color button. The working color of purple wispy glass has now been transferred onto the button.

Note that another way to get the purple wispy glass on the color button would be to use the "Match Palette to Design" function discussed above.

Please save your recolored flag design before continuing.

- Glass position and rotation

It is easy to change the position and rotation of the glass images in your design. To see how this works, start by entering Glass Orientation mode using the toolbar button shown at the left. (If you have only the Standard or Professional Edition then you’ll see a message informing you of your upgrade options; click "Proceed" to continue.) Now position the mouse pointer over the star. To move the glass image, simply drag the glass to another location: hold down the left mouse button, move the mouse, and then release the button.

Rotating the glass is just as easy. With the mouse pointer on a glass image, use the right and left arrow keys on your keyboard to rotate the glass clockwise and counterclockwise. If you have a mouse wheel, turning the wheel will rotate the image.

By holding down the Ctrl key while positioning or rotating the glass, you affect all pieces of the same color.

Close the flag design without saving it.
Transparency

The Professional Plus and Enterprise editions of Glass Eye 2000 allow you to set the transparency of the glass in your designs. Imagine having a photograph of the intended location for your stained glass project. You could then import that image as a background and then place your design in front of it with a suitable transparency value. There’s no better way to preview how your project will look when finished!

No matter what edition of Glass Eye 2000 you have you can try the following test. Open the design called “View” in the Tutorial folder. Notice that you can see the background image through the design. If you’d like to see the background image on its own, simply delete the design by doing a Select All and then a Cut (easily done with two keystrokes: Ctrl+A and Ctrl+X); after you’ve seen the background image, use the Undo command to restore the design.

Now use the Color Options command on the View menu. Drag the slider up and down to change the transparency level. You’ll see the effect immediately. The slider affects the opacity of all glass images in a design evenly. If you want to change the opacity of individual glass images, use the slider that was introduced in the section “Zooming in on glass” above.

Be aware that designs with transparency take longer to draw on your screen than designs that are 100% opaque. When you don’t need the transparency feature, use the Color Options command and move the opacity slider to the top.

Close this design without saving it.
Lesson 10: Text and Piece Labels

In this lesson you will learn how to add text to your designs. This includes the ability to have arbitrary notes and instructions on your design, as well as having your pieces numbered automatically. You’ll also learn how the "AutoTrace Text" command lets you incorporate lettering into your designs, a feature available in the Professional Plus and higher editions.

If you have the Standard Edition then text is not available, and piece numbering is limited to number-by-color.

Text

Open the flag design once again. Press the Zoom Out key (the minus key) three times so that we have some working room around the flag.

Click the toolbar button with the "A" on it, or choose "Add Text" from the Text menu. Doing so puts you in text mode. Your cursor will change to an "A" with a right angle in the upper left. Move the cursor to somewhere off the flag and click once. A box will appear into which you may type any text you like.

![Text Input Dialog]

This is a patriotic pattern.
To move down a line of text simply hit the Enter key. Increase or decrease the size of your text or change its font using the buttons in the upper right corner. When you have completed your text, click the OK button.

You can move your text by dragging it with the mouse, just as you did with knots and lines. If you wish to change your text, double-click on it and then make your corrections. If you wish to hide text temporarily then use the Show Text command, which will toggle text on and off.

Before we continue, delete any of the text you've added by clicking on it and then pressing the Delete key. Once you've removed all the text, press the Enter key to Zoom All.

**Piece Labeling**

Automatic piece numbering is one of the handiest features. Just select "Piece Labeling" from the Text menu and then check "Show numbers." You'll immediately see each piece in your design uniquely numbered.
If the numbers appear either too large or too small, you can change the font by clicking the "Set for Normal Pieces" button. Note that there is another button used to set the font used for small pieces. Glass Eye 2000 will use this font if the piece is too small to contain the number at the normal font.

If you have the Professional or higher edition, or are in trial mode, there are more options available. Look at the area labeled "Automatic numbering." When you choose "Number by color" then the numbering is color grouped so that numbers assigned to a particular color are consecutive. When you choose "Number by location" then your pieces are numbered strictly top to bottom regardless of color. "Manual numbering" is needed only when you want total control over the assignment of numbers to pieces. If you're curious about it, click the "Help" button for a complete explanation.

When you're ready, uncheck "Show numbers" and then click the OK button.

■ Color codes

You'll recall from Lesson 9 that the Color Selector has an area for defining a code for any color. So in our flag example we could assign R to red, W to white, and B to blue. Or you could use the letters A, B, and C if you wish. If you have the Standard Edition this feature is not available, so you should skip this part of the lesson.

Try this now by double-clicking the white color button to bring up the color selector. For "Color code in this design" enter the letter A and click the OK button. Following the same procedure, give red a color code of B and blue a color code of C. Now choose "Piece Labeling" from the Text menu and check "Show color codes." You will now see your codes within each piece. Now check "Show numbers" as well to see both color codes and numbers.

The codes you assigned are applied individually to each design, so different designs can have different coding systems. If you wish to have a system of codes that applies uniformly across designs, enter your code instead into the field labeled "Color code across designs."
Before we end this lesson, notice the two options at the bottom of the Piece Labeling dialog box. The "Improve readability..." option is provided because piece numbers can be hard to read when placed on highly textured glass. Enabling it causes the piece number to be placed within a rectangle of solid color. The "Use part names for unassigned color codes" option is a quick way of using the glass part names as the labels for your pieces. Experiment with these options now if you wish.

Close the flag design without saving it.

■ AutoTrace Text

The text you put into your designs using the "Add Text" command is intended for annotations or instructions. The text cannot be colored or rotated, nor does that text contribute to the calculation of materials usage, a feature you’ll see in the next lesson. If you’d like to make text part of your design, use the AutoTrace Text command.

Try this feature now. Start a new design and add text to it using the "Add Text" command. Click the "Change Font" button and select a font size of 72 so that your lettering is around ¾" high. After clicking OK, press the Enter key to do a Zoom All, making the text large in the view. Now select the text and then use the "AutoTrace Text" command on the Text menu. (If a license notification message appears, click the "Proceed" button.) When the trace is complete you will be asked if the original text should be deleted; click the "Yes" button in reply. You will now see lines in the shape of your original text. (The width of those lines depends on your default line properties settings. If the lines appear too fat, try using the "Show Hairlines" command.) You can now fill your text with glass colors and manipulate these lines like any others in your design. To learn more about AutoTrace Text, consult the Help system.

Close this design without saving it.
Lesson 11: Design Properties and Browsing

In this lesson you will learn how to set some general properties for a design, such as title and artist name. You’ll learn how to get materials usage and how Glass Eye 2000 can be used to help with accurate costing. Lastly, you’ll learn how to browse for designs and bevels.

- Design Properties

Open the design called "Barnaby" as you did in Lesson 1, then click the Properties toolbar button (or choose "Properties" from the File menu). The following dialog box will appear:
Here you have the general design properties, useful for categorizing your pattern. You are free to change these as you wish. The title and artist name appear on your printed pages, although you can prevent this by using the Page Setup command discussed in Lesson 2.

We'll see how to use these values when we discuss browsing later in this lesson.

Click the "Glass Usage" tab at the top to show the next page:

![Glass Usage](image)

This shows you the glass usage of the design color by color. We can see that the pale blue background consists of five pieces and occupies about 2½ square feet. Units (inches, feet, millimeters, centimeters, or meters) are set using the Units and Precision command as discussed in Lesson 2. If you want to see the name of a glass sample, let your cursor hover over it for a moment and the name will appear in a tool tip.
If you have the Professional or higher edition, you can enter prices into the column to the right of the area column. Glass Eye 2000 does not come with any preset prices and these are for you to enter as you wish. The currency symbol used (\$, £, ¥) is determined by the country setting that was established when Windows was installed on your computer.

If you have any color codes defined for a design they'll appear on top of the glass images. You can change these here by clicking on the image. If you have the Professional or higher edition, or if you're in trial mode, you can try this now by clicking an image and then entering its color code.

Now click the "Came Usage" tab:

If you’re doing a lead, zinc, or brass came window, this page will show you your came usage. (For copper foil you’ll see your materials usage on the Construction Cost page.) The Barnaby design uses two widths of came, and you can see the amount of came used for each of them.
The "Miscellaneous" page shows you a list of items other than glass and came that are required for construction. As the Barnaby design does not indicate any such items, we'll skip that page.

Now click the "Construction Cost" tab:

![Properties of Barnaby.eye dialog box]

This dialog box displays the materials usage of a design, and provides a spreadsheet for you to compute the construction cost or retail price. The cost of miscellaneous items, if any, will be brought forward from the Miscellaneous page.

You may enter monetary values for glass area, came/foil length, and number of pieces. You might choose to enter all three values or only one or two, depending on your preference. You may also enter a profit value in percent. Click the "Calculate" button to make the computation.
Your choice of came or copper foil on the Came Usage page determines whether you see a computation for came usage or a computation for copper foil usage. The formula used to compute these is different. Came use is computed as the sum of the lengths of all the lines. Foil use is computed as the sum of the circumferences of the pieces, plus the total length of overlays (lines that are not part of any circumference). Because most lines lie on the circumferences of two pieces, foil use is often almost double that of came use.

Click the "Notepad" button. This will start Notepad (a simple text editor that comes with Windows) with your Properties data as its text. You can now print the contents or copy the contents to another program. See the online help within Notepad for assistance with those functions. Choose "Exit" from Notepad's File menu to exit Notepad.

If you have lines, such as arrows or other annotations, that you do not want included in the came/foil calculations, select those lines and use the Line Properties command. There you'll see an option to exclude those lines from consideration.

If you would like to see the properties calculations for only a portion of your design, just select that portion before you use the Properties command. This capability is not available in the Standard Edition.

Click OK to dismiss the Properties dialog box.

Browsing

The design browser gives you a great way to look through your collection of stained glass patterns, both those that come with Glass Eye 2000 and those created by you. To start the browser, choose "Browse Designs" from the File menu or click the toolbar button shown here. Doing so will bring up a dialog box that looks something like what you see on the next page.
On the right you are shown small images of the designs called "thumbnail" images. Use the scrollbar along the right edge to view the entire library. If this is the first time you have used the Browse Designs command then the program will spend a few minutes generating the thumbnail images, but you can interact with the dialog box while this is happening.

The choice of which thumbnails are shown depends on your choices for the attributes on the left. Experiment with changing those attributes. For example, choose "Circular" for Shape to view circular windows only. If you type in a keyword, that word will be matched against a list of keywords associated with each design, and only those designs that match all the keywords will be shown. Changing the "Folder" will limit the designs shown to those that appear in the chosen folder, so you might wish to save your designs in the "My designs" folder to make them easier to find. The "Maximum difficulty" control lets you choose a difficulty threshold, so you can be shown only patterns that are easy enough for you.

Double-click on any thumbnail if you wish to open that design. You can also right-click on a thumbnail for more options.
If you wish to purchase additional patterns, click the "Buy More" button and you’ll be shown the pattern collections for sale on our website. Another way to see those collections is to visit www.dfly.com/patterns using your web browser.

In addition to browsing our design library you can browse our bevel library. Try this now by using the "Browse Bevels" command on the File menu. Here you have a collection of almost two hundred bevels that you can insert into your design. Double-clicking a bevel will insert it into your current design rather than opening it up as a new design. Glass Eye 2000 was not designed as a bevel manipulation system and our facilities for using bevels are very limited. Use the bevels as you wish, but remember that they're simply line drawings like any you might create yourself.

Close any open designs without saving them.
Lesson 12: Importing and Exporting

In this lesson you’ll learn about importing images into Glass Eye 2000, either from files or directly from your scanner or digital camera. You’ll also learn how to export your designs in file formats such as JPEG. We’ll also try out the powerful AutoTrace feature for automatically converting an imported image into a Glass Eye 2000 design.

Importing

Importing is the process of bringing into Glass Eye 2000 a design that’s been created elsewhere. You might have that design as a file on your computer or your might have it only on paper. If you have a file, then it might be an image (or "raster") file, which contains an array of small dots that form an image, or it might be a "vector" file, which contains a collection of entities such as lines, circles, text, and so on. Let’s discuss each of these scenarios in turn.

Importing an image file

You might have images such as photographs or stained glass window patterns that you’d like to bring into Glass Eye 2000. There are two main uses for importing an image:

- To bring in a pattern to trace over
- To bring in an image that will become part of the overall design

Begin by clicking the "New" toolbar button to start a new pattern, or by selecting "New" from the File menu. Choose "Add Background" from the File menu and select the "heart" image from the Tutorials folder. You will then see the Background Properties dialog box as shown on the next page.

The values shown for width and height are taken from the image itself, but you might wish to adjust those values. Rotate or flip the design as you wish. After
you click OK the image will be placed in the background of your design. Only one background at a time may be used.

You can choose "Background Properties" from the File menu whenever you wish to readjust the size or position of your image.

Change your line color to brass using the Default Line Properties command on the Modify menu, just as we saw in Lesson 5. You can now trace the design with the line drawing tools you used in earlier lessons. By choosing brass as your line color, the lines you draw will be easy to see on top of a black-and-white image. Trace some or all of the image—whatever you have time for now.

As you trace you might occasionally wish to hide the background by toggling the "Show Background" view property. The easiest way to do this is to click the toolbar button seen here; alternatively, you can use the "Show background" option within the View Properties command. Once you are sure you no longer need the background image, you can remove it permanently by using the "Remove Background" command from the File menu. After an image has been added the size of a design file will increase dramatically, so you will want to remove an image when you no longer need it.
Glass Eye 2000 can sometimes do the tracing for you. We’ll learn more about this feature, called AutoTrace Background, in the last part of this lesson.

Another use for a background image is as a realistic backdrop for your design. You can see this by starting a new design and importing the design called "Door" from the Tutorials folder. Change your line color back to black and draw a design in the opening of the door.

### Importing from your scanner or digital camera

Glass Eye 2000 allows you to bring in an image directly from a scanner or digital camera without first saving the image as a file. The technology used for this is called TWAIN and many design programs use "Acquire" for the name of this feature. Although these are perhaps not the best terms, we have adopted them in Glass Eye 2000 because they are well known.

If you have a scanner or other TWAIN source attached to your computer, you can try this feature now. Place an image on your scanner or have a photo ready in your digital camera. Start a new design and then use the "Acquire Background" command on the File menu. This menu item has two choices: "Select TWAIN Source" and "Acquire TWAIN Image." Use the former command to select the device you wish to import from, and then use the latter command to import the image. Once Glass Eye 2000 has your image, the importing process works exactly as it does for files.

Even though the "Acquire TWAIN Image" is able to copy the current image from your digital camera, for cameras the "Add Background" command often works better. When connected to your computer, modern digital cameras act just like any other file folder. Using the "Add Background" command you should be able to navigate to the file folder representing your camera and add as a background any image stored in its memory. Consult your camera’s documentation for details about connecting your camera to your computer.
More about backgrounds

The background feature is great for scanning in a pattern and then resizing it to the dimensions you need. Simply print actual size (using the Page Setup command) and don’t draw at all. Be aware that scanned pattern images do not provide the color coding nor the piece numbering available on a drawn Glass Eye 2000 pattern.

You’ll be pleased to know that the eyedropper feature from Lesson 9 works on your background image. You can try this by entering color mode and then holding down the Shift key while you click on your image. The color you click on becomes the working color.

Importing a vector file

The Professional Plus and higher editions have the ability to import a file created in other design software, such as Adobe Illustrator, CorelDraw, and AutoCAD. Your file needs to be in WMF, EMF, DXF, or DWG format. If you have a design in another software package but your design is not stored in one of these formats, look for an "Export" or "Save As" command in your software and pick one of the four formats that Glass Eye 2000 can import. If you have a choice, DXF and DWG are better at preserving size and other formatting information than WMF and EMF.

Just as translating a story from one language to another doesn’t always preserve the nuances, translating between file types sometimes results in a loss of accuracy. After you import you should check your design carefully. You might have to do a little cleanup by hand to get it perfect.

If you already have a WMF, EMF, DXF, or DWG file you may try importing it now. Use the "Import Design" command on the File menu. You’ll see a few options after you select your file, and if you need an explanation of those options just press the Help button.
Exporting

Glass Eye 2000 supports exporting in a variety of file formats. The Standard Edition supports BMP and JPEG, while the Professional and higher editions add TIFF, PNG, PCX, WMF, EMF, and DXF formats. If you’re not sure which format to use, JPEG is generally a good choice.

Try this now by opening up the flag design we've used in previous lessons. Zoom in or out until the flag is at the size you want. Then use the "Export Design" command on the File menu. You will be prompted for the name of the file, as well as its file format. Navigate to the folder where you want the exported file to be placed, and change the filename if you wish. Choose a format of JPEG and then click the Save button.

If you would like to export only a portion of your design, just select that portion before you use the Export Design command. This capability is not available in the Standard Edition.

A different way to export a design is to use the "Send Design via Email" command on the File menu. If your email system is compatible with Glass Eye 2000 then you'll be able to send the active design to a customer without even first saving as a file—all you need to do is to select the file format. If this command fails to work properly for you it is because your email system is incompatible, but you can always export your design as a file and then send it as an email attachment.

Close any open designs without saving them.
AutoTrace Background

There are two primary reasons for bringing in an image to trace. One is that you have a photograph of something (say, a flower) that you would like to interpret in stained glass. The other is that you have a line drawing of a stained glass pattern, usually on paper, and you wish to convert this into a Glass Eye 2000 design so that you can take advantage of program features such as coloring and resizing. The first of these is an artistic endeavor best left to humans, and Glass Eye 2000 does not try to automate the process. But the second requires no artistic inspiration, and here Glass Eye 2000 can help a great deal. The "AutoTrace Background" command, included in the Professional Plus and higher editions, can do the tracing for us.

Let's see this in action. Repeat the steps at the beginning of this lesson where you started a new design and then imported the "heart" pattern from the Tutorials folder. When you see the Background Properties dialog box just click OK without making any changes, and finally press the Enter key to zoom in on the heart so that it fills the view.

From the Draw menu choose "AutoTrace Background." (If you have only the Standard or Professional Edition then you'll see a message informing you of your upgrade options and letting you know that the results of the AutoTrace cannot be saved; click "Proceed" to continue.) The AutoTrace Background dialog will appear on your screen:
For now, just ignore the options and click the "Trace" button. The design will be traced in a matter of seconds.

To see the trace, turn off the background using the Show Background view property, the same one you used earlier in this lesson. Try turning on knots, coloring, or moving the lines and you’ll discover that this is not just a static image but a well-connected line drawing!

For most scanned images you won’t need any of the options offered by the AutoTrace Background command, and you’ll be able to trace simply by pressing the "Trace" button. For some unusual images, however, you might need to take advantage of those options. For example, notice that your first option is a choice between a centerline trace and an outline trace. Most stained glass patterns would require a centerline trace, but there are times when you might wish to trace along the outside edges of your shapes rather than through their centers.

The following diagram should make the difference clear:

```
original image  centerline trace  outline trace
```

To learn about the other options, click the Help button for a detailed explanation.

The heart image we used was a very clean line drawing. If your image is imperfect, there are tools that allow you to lend assistance by pre-cleaning the image before the AutoTrace process is performed. If you’d like to take advantage of those features, it helps to know that AutoTracing is actually performed on a monochrome copy of your background image. A
"monochrome" image is one containing only black and white pixels—no grays or color. By clicking the "More" button the image preparation area is revealed, giving you access to controls which allow to you help Glass Eye 2000 produce a clean monochrome image, suitable for AutoTracing.

The most commonly used options are "Speck removal" and the slider bar that brightens or darkens the image. Again, click the Help button to learn more about these options. After you apply an option, use the "Zoom In" button to take a closer look at your image. You can also use your mouse to pan the image. Because the heart image is already clean then many of these options will have little effect, but feel free to experiment and to get accustomed to zooming and panning the monochrome image.

Please conclude this lesson by closing your design without saving it.
Lesson 13: Crosshairs and Grid Lines

In this lesson you’ll learn how the crosshairs and grid lines can be used for the alignment of knots and lines. You’ll also learn how to change the colors used for crosshairs and for selections, and options for changing the appearance of lines.

Remember the mushroom figure you created in Lesson 5? We will use that design in this lesson, so open that file (in the Tutorial folder) now. After the file is opened, enable Show Knots.

If your mushroom came out lopsided, you might be wondering how to get one that is perfectly symmetrical. This lesson will focus on tools for making your designs more precise.

Crosshairs

The crosshairs are perpendicular lines that you can position in the view. There are two types of crosshairs. The most commonly used consists of a horizontal and a vertical line. You can show them using the first of these toolbar buttons. The other style consists of two diagonal lines, shown using the other button. Both styles of crosshairs operate in the same way: if a knot is created or moved near a crosshair, the knot will be positioned directly under that crosshair. And if a crosshair is moved near a knot, the crosshair will be positioned directly over that knot.

Let’s use the crosshairs to line up the knots in the mushroom design. The mushroom you created should look something like the one shown on the next page. (If it doesn’t, drag some knots until it approximates this shape.) Click the toolbar button that shows the horizontal/vertical crosshairs. Crosshairs appear in the view, most likely as two perpendicular red double lines, although the style of the lines can be changed in View Properties. You may or
may not see the crosshairs depending on whether the crosshairs are within the bounds of your view. If you don't see both crosshairs, try pressing Zoom Out (the "-" key) two or three times. If you still don't see them, choose "Set Crosshairs Origin" from the View menu and then click somewhere in the view. The **crosshairs origin** is the point where the crosshairs intersect.

Now that your crosshairs are visible, let's position them. You move crosshairs just like you move knots: by dragging them around the screen. Drag the horizontal crosshair over the leftmost knot and release the mouse button. Be sure the pointer itself, not just the crosshair, is over that knot when you release. In a similar fashion, position the vertical crosshair over the topmost knot. When you have finished, your view should look something like what you see above.

Now drag the rightmost knot down to the horizontal crosshair. Doing so makes the line representing the underside of the mushroom perfectly horizontal. Do not work too hard at positioning the knot exactly under the crosshair; just release it near the crosshair and the computer will position it exactly for you.
Drag the slider (the white knot) to the intersection of the crosshairs. And drag the bottommost knot to the vertical crosshair. The "stem" of the mushroom now lines up perfectly below the topmost knot. Your design should now look something like the bottom figure on the previous page.

Now the knots line up perfectly. If you doubt the accuracy, zoom in on one of the knots. Even if you zoom far in, you will discover that each knot sits exactly under a crosshair.

Now try moving one of the crosshairs. Notice that this does not affect the design: the knots are not "stuck" to the crosshairs. The relationship between knots and crosshairs is a temporary one by design.

Turn off crosshairs by clicking the Show Crosshairs toolbar button again.

Grid lines

Although the knots of the mushroom design line up well, your design might not be symmetrical. This is because we have done nothing to ensure that the leftmost and rightmost knots are the same distance from the stem line of the mushroom. In our last diagram, you might have noticed that the mushroom extended to the right more than it did to the left.

We can achieve the desired balance using grid lines. To see the grid, click the Show Grid toolbar button now. When grid lines are on, you see your design against a background of regularly spaced lines.
You now see the grid lines, but to make them even more useful we can turn on automatic grid snapping. This will cause every knot, when created or moved, to be positioned over the nearest grid line intersection point, known as a "grid point." Turn on Auto Grid Snap now by clicking its toolbar button. Now drag each knot, one at a time, close to a grid point. It should be easy to make the mushroom symmetrical.

You can, of course, specify the spacing of the grid lines, but this takes more than the click of a button. To set the spacing you need to use the View Properties dialog box. To bring up the dialog box (shown on the next page), press Ctrl+E or choose "View Properties" from the View menu.

As you see, there is a lot you can do in this dialog box. Some of the options (Show rulers, Show knots, Show colors, etc.) we have seen before as buttons on the toolbar.

Let's focus now on the fields available for horizontal and vertical spacing of grid lines. Here is where you enter whatever you want the spacing to be, even making the horizontal spacing different from the vertical spacing if you wish. Grid lines start at the zero position on the rulers, and are offset from there at the specified spacing values. If you want a thicker grid line to appear at regular intervals, use the "Block size" option. For now, just enter 2 for the horizontal spacing and 3 for the vertical spacing, then click OK to see the effect of those changes.
More view properties

While we're here, let's complete our understanding of view properties. Bring up the View Properties dialog box again. As we have seen, some view properties can be set using toolbar buttons. Here are those properties that can be set only from this dialog box.

- Line style. Show each crosshair as a single line or a double line.
- Crosshairs color. If your design contains a lot of the color currently used by the crosshairs, you may find the crosshairs hard to see. You can change their color by clicking this button.
• Block size. Show a thicker grid line at regular intervals to make measuring easier.

• Line appearance. Lead lines can be viewed in four different ways: face width, heart thickness, face and heart, and hairline. The images below show the line appearance for each of these options. Sometimes you want lines of any color to appear in black, so there's an option for that too.

  - face width
  - heart thickness
  - face and heart
  - hairline

• Selection color. The selection color is the color used for selected lines and knots. The color is usually yellow. If your design contains a lot of the selection color, you can change it to some other color to make selections more visible.

• Drawing surface color. Pick either gray, light gray, or white for the background color in the view.

Click "Cancel" to dismiss this dialog box. Turn off grid lines and close this design. When asked if you want to save changes, click "Yes."
Lesson 14: Cut, Copy, and Paste

In this lesson you'll learn to duplicate parts of your patterns using the Cut, Copy, and Paste commands.

Common to many Windows programs are the three commands Cut, Copy, and Paste. Cutting, copying, and pasting are all interactions with the Windows "Clipboard." The Clipboard is simply a special storage place where items can be placed with Cut and Copy and retrieved with Paste.

Open the "Mushroom" file once again. After it loads, press the Zoom Out key (the "–" key) twice to reduce the image of the mushroom.

Using a select box, select the upper part of the mushroom—all but the stem. Now click the Cut toolbar button, shown at the left. The upper part of the mushroom disappears, and is placed on the Clipboard.

Let's open a new design and retrieve what we cut. Use the New command to get a new, blank design. Now click the Paste button.

You have now pasted part of one design into another design. The pasted line sections are selected, so they are easy to drag to another location. Go ahead and drag the design to any corner of the view and then click Paste again. You now have two mushroom tops. As you see, a Paste copies the Clipboard contents and places them into your design, but it does not remove anything from the Clipboard.

If the crosshairs origin is visible in the view (meaning that you can see the point where the crosshairs intersect) then pasting centers the contents at that point; otherwise, pasting places the contents in the center of the view. Experiment again with pasting while having the crosshairs visible.
Close this design without saving it. We are now back to the mushroom design as we left it, with only the stem remaining. Click the Undo button to restore the top of the mushroom.

Now use a select box to select the entire mushroom. This time try a Copy operation by clicking the Copy toolbar button. (You will not see much feedback to let you know that the operation succeeded, other than the button going in and out.) Like Cut, Copy places the selection on the Clipboard, but unlike Cut it does not remove the selection from the design. Both Cut and Copy will erase the previous Clipboard contents to make room for the new selection, so the mushroom top that used to be on the Clipboard is now lost.

Instead of opening a new design, let's scroll the current design. Using the bottom scroll bar (or using panning, if you prefer) scroll the view so that the mushroom is positioned at the very left side of the view. Now click the Paste toolbar button. You now have two mushrooms! You can probably imagine that this process is useful when your design contains repetitive patterns.

Now close the design without saving it.

■ Deleting

Before we conclude this lesson let us mention the Delete command, which is similar to Cut. Delete does not have a toolbar button—you use either the Del key or the "Delete" item on the Edit menu. Delete removes the selection from the design, but it does not put the selection on the Clipboard. The only time to use Delete instead of Cut is when you want to remove something from your design but do not want to disturb the contents of the Clipboard.
Lesson 15: Advanced Lines

In this lesson you'll gain an advanced understanding of curves and arcs, including some of the limitations of arcs. You'll learn how to draw a perfectly horizontal, vertical, or diagonal line. Lastly, you'll learn about discontinuous lines and also about joining and breaking lines.

As you know, the way to draw a line is to specify the location of knots and to let the computer calculate the shape of a smooth line that passes through them. The smoothness property is important. For example, consider these figures:

The placement of the knots is the same in each case, but the figure on the left is smooth whereas the figure on the right has a sharp corner. This is because the figure on the left is composed of one line and the figure on the right is composed of two lines that share a common knot. Thus, keep this rule in mind as you draw:

If you are trying to draw a “line” that is not smooth, draw it as a series of smooth, connected lines.
Curves and arcs

Glass Eye 2000 supports two line types: curves (more precisely known as "spline curves") and arcs (more precisely known as "elliptical arcs").

Think of curves as what you might get by drawing a graceful line freehand with pen and paper. To the right is a curve.

An arc is something else. It is always all or part of a circle or ellipse. To the right is an ellipse.

So an arc might look like this.

Only horizontal and vertical arcs are supported. An arc based on a tilted ellipse like this is not possible.
Now consider, for another example, these two lines:

Each line is fit through three knots arranged in exactly the same pattern. But the line on the left is a curve, whereas the line on the right is an arc. For the first part of this exercise, start a new design and then draw these two lines as shown. Use the Curve toolbar button or the Curve command on the Draw menu to draw in Curve mode. Use the Arc command on the Draw menu to draw in Arc mode.

There is a significant difference between curves and arcs: given more than three knots, there is always a curve that can be drawn through them, but there is not always an arc.

Consider the four knots in the top figure at the right. Here you see a smooth curve going through the knots, but clearly there is no ellipse that touches all four of these knots.

If you were to place knots in that configuration by distorting an ellipse, you would get something like what you see here. The line is drawn as a series of arcs, which is the best the computer can do. Notice how the line is not smooth where it goes through the bottom right knot. This illustrates the one exception to the rule that says that a line is
always smooth: if no smooth arc goes through all the knots, the line will not be smooth.

There is yet another complication when drawing ellipses. Consider four knots arranged in the pattern at the right. There are many ellipses going through these points.

Here is one: Here is another:

Which ellipse you get will be an arbitrary choice by the computer, so you might not get the shape you want with the knots so arranged. Therefore, it is recommended that when reshaping an ellipse you keep the knots at the top, bottom, left, and right. For example:

When the knots are arranged like this there is no ambiguity.
Because of these complications, remember this rule:

---

**Use curves, not arcs, for all lines except when you are very sure that an arc is required.**

---

**Horizontal, vertical, and diagonal lines**

A perfectly horizontal, vertical, or diagonal line can be hard to draw. You could use crosshairs or grid lines for these, but a simpler way is to use the Shift key as we saw in Lesson 4. Let's try this now.

Use the "Drawing Properties" command on the Draw menu and make sure that the number of divisions is set to 8 and the angle of rotation is set to 0. Doing so will constrain drawing to the eight compass directions when the Shift key is held down. Click OK to dismiss the dialog box.

Now enter Curve mode by clicking the Curve toolbar button. Click anywhere on the screen to choose the starting point of the curve. Now before you click again, hold down the Shift key while you move the mouse in a circle around the starting point. Notice how the line is constrained to be horizontal, vertical, or diagonal. When you have the line the way you want it, double-click as usual to complete the line.

**Joining lines**

Let's say you have drawn the curve shown here. You are satisfied with the positions of these knots, but you wish to make the curve extend further to the right. What you would like to do is to add a knot somewhere off in space to the right of the curve, but there is no facility for adding knots except along existing lines.
You could draw another line starting at the rightmost end of the current line, something like what you see here. This is not a complete solution, however, because the resulting "line" is not smooth. It's really not one line at all but two lines that connect at a knot.

What you want is to join these two lines into one smooth line. Once combined, the resulting line would look like this.

Try this now. First make sure the Sticky property is on. Having Sticky on will make sure the two lines you draw will share a common knot. Draw two curves such that the ending knot of one curve is the starting knot of the other. You can approximate the shapes of the curves above or invent something of your own.

Now select at least one line section from each curve. You can use a select box or the Ctrl key while clicking to do this. Choose "Join Lines" from the shortcut menu. You must have line sections from exactly two lines selected for the "Join Lines" item to be available. After you choose this item, your two lines will be joined into one.

Sometimes you want to go the opposite way and break one line into two. Try this now by selecting one of the inner knots on the line and then choosing the Break command on the Modify menu.

- **Discontinuous lines**

A distinguishing feature of Glass Eye 2000 is that the lines you draw need not be continuous. Try this by drawing something similar to the following curve, composed of three sections.
Now select the middle section and delete it. The result is what you see in the upper figure to the right. See how the curve retains its shape even though a section is missing! What you have is one curve composed of two sections. You know you don't have two curves, because if the delete operation had separated the curve into two the result would have been what you see in the lower figure, which you are not seeing.

You can easily reconnect a disconnected line. One way is to drag one knot over to another across the gap. Try this now. Enter Pick mode and drag one of the middle knots over to the other. If Sticky is on, the two knots will become one and the line will be continuous. Of course, you haven't restored the line to its original shape because now you have three knots instead of four. To restore the missing piece we need another procedure.

Click the Undo button to make the line discontinuous again. Bridge the gap by drawing a curve across it; you now have two connected lines. Select the new line and at least one section of the original line, then choose "Join Lines" from the shortcut menu. The two lines combine into one and the curve is restored to its original shape.

Discontinuous lines are common in stained glass design. Look at some window patterns and you will probably notice them. To the right is one example. The arcs along the outside of the figure form a circle that has been made discontinuous by removing some of its sections.

Close your design without saving it.
• U-came borders

Most of the lines that you draw are H-came, meaning that the face width is centered along the heart thickness. The Professional and higher editions have the ability to make a U-came border around your design. The following diagram shows the difference:

![H-came border](image1) ![U-came border](image2)

Try this now by starting a new design and drawing a square in it. Use the "View Properties" command and set a line appearance of "face and heart." Your square should look something like the first figure above. Now choose "Make Frame" from the Modify menu. (If you have the Standard Edition then you'll see a message informing you of your upgrade options; click "Proceed" to continue.) Your square will be transformed to have a U-came border like the one in the second figure. You can now continue to work with these lines as you would any other lines. Be sure that the Sticky option is enabled and try drawing some lines inside the square from one border line to another.

U-came lines are available as border lines only. If a line is not along a border, it cannot be made into U-came. Moreover, if one line on the border is U-came then they all must be.

Close your design without saving it.
Lesson 16: Moving and Resizing

In this lesson you’ll learn how to use five commands for moving and resizing your designs:

- Stretch
- Resize
- Rotate
- Move
- Scale

Once you have made a figure out of lines, there are several features available that allow you to position and size that figure exactly the way you want. We’ll use the "Mushroom" file once again, so open up that file (in the Tutorial folder) now. Zoom Out twice (by pressing the "–" key) to reduce the image of the mushroom.

The five commands discussed in this section are found on both the Modify menu and the shortcut menu, introduced in Lesson 6. To simplify, we will assume that you will use the shortcut menu for all menu selections, but you can use the Modify menu if you prefer.

Stretch

One method of resizing is stretching. Choose "Stretch All" from the shortcut menu. Doing so places a stretch box around the entire figure.
You can now stretch the box by dragging one of the eight resize handles that lie on its perimeter. Each handle provides a different stretching operation. For example, by dragging the handle in the middle of the left side of the stretch box, you can make the mushroom fatter or thinner.

Experiment with the stretch box now. Try dragging some of the handles to resize the figure. You must position the pointer precisely over the handles—notice how the pointer changes when you do so. If you don't grab a handle but put the mouse within the stretch box and drag, you will move the selection without changing its size.

You can change the way stretching occurs by using the Shift or Ctrl keys while you drag a handle. If you hold down Shift, the box maintains its aspect ratio, meaning that the proportion of width to height is kept constant as the box is resized. Experiment now by holding the Shift key down while you drag a handle and the meaning should become clear.

The other option is to hold down the Ctrl key, which causes the box to maintain its center while it is resized. Give this a try now. Also try holding down both the Shift and Ctrl keys. They work quite well together.

Remove the stretch box now by pressing the Escape key or by switching to another mode, such as Pick mode.
**Resize**

We saw how to use the Resize command in Lesson 1 so we won't repeat that exercise now, but here are a few more things to know about resizing your patterns.

First, as in all dialog boxes, the figures you are shown for the height and width when the dialog box first appears are rounded as specified in the Units and Precision dialog box. See Lesson 2 if you need to review units and precision.

Second, for typical H-came the widths and heights are measured from the middle of the lead lines. The diagram below, with some very thick lead lines, should make that clear.

![H-came measurement](image)

Measuring in this manner allows you to change the lead size and not affect width or height as understood by the computer. For U-came borders, the width and height are measured from the outside. Note that changing border lines to U-came still does not change the overall dimensions of the border.

If you use H-came borders but need a precise width or height as measured from the inside or outside edge of the lead, add or subtract the lead size from your measurements to compensate.
Finally, the "Anchor" control determines which point of your design remains fixed during the resizing. By default the center remains fixed, but if you wish you can change the fixed point (called the "anchor") to the centers of the sides or the corners of your design.

- **Rotate**

The Rotate command allows you to rotate your design (or a portion of it) around a point. Try this now by choosing "Rotate All" from the Modify menu. The cursor changes to a new shape and a black and white pivot-point marker is placed at the center of your design. Position the cursor in some blank area of the view, hold down the left mouse button, and drag. Your design will rotate around the pivot point.

As you move the mouse you'll notice a numeric display next to the cursor indicating the degrees of rotation. This value is precise, meaning that your design is rotated by exactly the amount shown. By default the rotation angle is rounded to the nearest 1° but this value can be changed using the Units and Precision command you saw back in Lesson 2.
You can have greater precision by holding down the Ctrl key while you rotate. Doing so will increase the precision by a factor of ten. Try this now, and you’ll see your rotation precision change from 1° to 0.1°.

The pivot point of the rotation can be moved. To do this, click at some other point in the view. The pivot point will move to the new location and will become the center of subsequent rotations.

You can use the arrow keys to rotate even without choosing the Rotate command. Hold down the Alt key while pressing the up arrow to rotate clockwise or the down arrow to rotate counterclockwise. You’ll first have to select the lines to rotate for this method to work, however.

To leave rotate mode, use the Escape key or select another mode from the menu.

There is something to look out for when using the Rotate command. As discussed in Lesson 15, tilted arcs are not supported, so if you rotate arcs by angles other than 0°, 90°, 180°, or 270° (or their equivalents) you will probably end up with a strange design. Try this now. Choose “Ellipse” from the Draw menu and draw an ellipse somewhere off to the side of the mushroom.

Now select the entire ellipse and rotate it. At times while you rotate you’ll see a figure like this. The result is a series of connected arcs, which is probably not too useful. Go ahead and delete this figure now!
## Move

The Move command moves (or copies) the selection horizontally and vertically by specified amounts. You use Move primarily if normal dragging with the mouse does not give you enough precision on the distance of movement.

Let's try it now. Select some part of the entire mushroom (perhaps a knot or a line section), then choose "Move" from the shortcut menu. You will see this dialog box.

Type in 2 for the horizontal offset, 3 for the vertical offset, and choose "Move." Click OK and your selection will move up and to the right by those amounts. If you don't like the result, click the Undo button to reverse the change. Also try the experiment with a Copy instead of a Move.

## Scale

Scaling causes a selection to be resized by specified scale factors. This is much like using a stretch box, but it gives you precise control over the amount of resizing. Thus, if you wanted to double the size of a design you could scale by a factor of 200% and the design would be exactly twice as big as before.
Choose "Scale All" from the shortcut menu to bring up this dialog box. Uncheck the "Maintain proportions" option so that you can set the horizontal and vertical scale factors independently. Type in 200% for the horizontal scale factor and 50% for the vertical scale factor. Click OK and you will make your design twice as wide and half as tall. Note that like the Resize command, the Scale command also has an anchor control.

A value of zero is acceptable as a scale factor. This is useful as a way of making a line perfectly horizontal or vertical. Let's try this now. Somewhere in the view draw a wavy line that stretches out horizontally, something like this. Now enter Pick mode and select the entire line. One easy way to do this is to double-click on it: double-clicking on a line selects the whole line, not just one of its sections. Once the entire line is selected, choose "Scale" from the Modify menu. Type in 100% for the horizontal scale factor and 0% for the vertical scale factor. Click OK and the line will be squashed flat!

Close the current design, but don't save your changes.
Lesson 17: Flip, Reflect, and Repeat

In this lesson you'll learn how to reverse patterns with the Flip command and how to create mirror images of patterns with the Reflect command. You'll also learn how to make several copies of a pattern with the Repeat command.

Flip

To flip a design is to turn it into its mirror image, either by inverting it left to right (called a "horizontal" flip) or top to bottom (called a "vertical" flip). Let's try some flips on the flag design that we used in Lesson 9 when we experimented with color. Load the "Flag" file now.

Just for fun, turn color off for this lesson since we won't be using it. (Do so by clicking the Show Colors toolbar button.) You should also Zoom Out a couple of times so that the design occupies only a small part of the view.

Choose "Flip All" from the shortcut menu. Notice that a second pop-up menu appears, asking you whether you want to flip horizontally or vertically. Choose "Vertically." The design will be flipped top to bottom.

Do another flip, but this time flip horizontally.
Click the Undo button twice to restore the flag to its original orientation.

Reflect

Reflecting is a way to make a mirror image copy of a design. Reflecting is always done across crosshairs, so you must have the crosshairs visible whenever you want to use this command.

Let's first use the horizontal/vertical crosshairs for reflecting. Make those crosshairs visible by clicking the Show Crosshairs toolbar button. Position the crosshairs origin (the point where the crosshairs intersect) just under and to the right of the flag. (If the button is pressed in and you don't see the crosshairs, choose "Set Crosshairs Origin" from the View menu.) Your view should now look something like this.

Choose "Reflect All" from the Modify menu. A second menu will appear asking you to choose between three kinds of reflections:

1. Across | means "across the vertical crosshair"
2. Across — means "across the horizontal crosshair"
3. Across Both means "across both crosshairs"
Choose the first item to reflect the design across the vertical crosshair. Your view should now look like this:

![Diagram of reflected star on flag]

If you have clicked nothing else, the flag to the left of the vertical crosshair should still be selected. (If it isn’t, make it so.) Choose “Reflect” from the Modify menu, and this time choose the second item from the menu to reflect across the horizontal crosshair, which will make a flag below the selected flag. Finally, do another reflection that reflects across both crosshairs.

Click the Undo button three times to return to a solitary flag.

Now click on the Show Crosshairs button that brings up the diagonal crosshairs.

Position those crosshairs to the right of the flag.
Select the entire flag, and then again choose "Reflect All" from the shortcut menu. Because you now show the diagonal crosshairs, you see a slightly different second menu:

1. Across \ means "across the crosshair that goes from the top left to the bottom right"
2. Across / means "across the crosshair that goes from the bottom left to the top right"
3. Across Both means "across both crosshairs"

Choose the first item. Your view should now look like this:

Continue your experimentation by choosing the other two reflection methods, just as you did with the horizontal/vertical crosshairs.
Repeat

If you want more than one copy of a design, you’ll find the Repeat command useful. With this command you repeat your design, or a portion thereof, at regular intervals. There are three repeat patterns available:

- Linear
- Circular
- Rectangular

Let’s try each of these in turn. Start by clicking the Undo button until you return to a solitary flag. Now use the "Repeat All" command on the Modify menu. (If you have the Standard Edition then you’ll see a message informing you of your upgrade options; click "Proceed" to continue.) Select the "Linear" tab and specify 3 repetitions along a 45° angle spaced 15" apart. Click OK, and then do a "Zoom All" to see the result, which should look like this:

![Result of Linear Repeat]

Your original flag is included as one of the repetitions.

Click Undo and let’s try another one. Before doing so, use the Set Crosshairs Origin command and set the origin of the horizontal/vertical crosshairs to somewhere around 16" to the left of the flag. (Turn on the rulers if you need to.) Now use the "Repeat All" command again and select the "Circular" tab. Choose 8 repetitions with "petal" orientation. Petal orientation will rotate your design as it copies it around the crosshairs origin, making a pattern like the petals of a flower.

![Result of Circular Repeat]
Your result should look like this:

Click Undo and try again, this time with “clock” orientation. With this option the design is not rotated, just as you see with the numbers on a clock face:
Lastly, click Undo and try "Repeat All" once more and select the "Rectangular" tab. Choose 4 columns, 3 rows, a column offset of 20" and a row offset of 15". The result should be an array of flags:

When you’re finished, close this design without saving your changes.
Lesson 18: Lamp Wizard and More

In this lesson we’ll introduce the Lamp Wizard feature for designing panel lamps. We’ll start, however, with some drawing commands that were not covered in earlier lessons: Yank, Group, Set Knot Location, and Snap to Grid, and Straighten.

If you aren’t interested in the Lamp Wizard you may skip that part of this lesson, but all Glass Eye 2000 users will benefit from learning these five new commands.

Begin by starting a new, blank design. As always, be sure that Sticky is on!

- **Yank**

Create a design with two curves that share a knot, something like what you see on the right.

Let’s say that you want to separate the lower line from the upper one by pulling it off the knot that connects the two, like what you see here.
This is easy to do with the Yank command. Enter Yank mode by clicking the Yank toolbar button. If you are running in low resolution you might not see this button on the toolbar, and you can choose "Yank" from the Edit menu instead.

The pointer now looks like the hand on the Yank button. Position the fingertips on the line near the knot. Don’t place the fingertips right on the knot; place them on the line you want to yank, and near the knot you want to yank from, like this.

Now drag the mouse to a new location. When done, return to Pick mode.

The rule to remember about yanking is:

```
Don’t yank on a knot; instead, yank one end of a line section off a knot.
```

- Group

Collections of lines can be grouped so that they can more easily be moved in unison. Try this now by selecting both of the lines in your drawing (a select box is the easiest way) and then using the Group command on the shortcut menu. Notice that now when you select either line you select both. Now ungroup the lines by selecting the group and then using the Ungroup command.
Set Knot Location

Sometimes you want to position a knot precisely by typing in its horizontal and vertical location. For example, let's set the location of the lowest knot in the design you just created. To do this, select the knot (by clicking on it) and choose "Set Knot Location" from the shortcut menu.

Whatever numbers are shown give the current location of the knot. To set a different location, type in new numbers and click OK.

Snap to Grid

In Lesson 13 you learned that when "Auto Grid Snap" is enabled, knots will snap to grid points when created or moved. Another way to use grid snapping is the "Snap to Grid" command, which causes all selected knots (or knots adjacent to selected line sections) to be moved to their nearest grid points.

Try this now. First, make grid lines visible by clicking the "Show Grid" toolbar button. (The "Auto Grid Snap" feature can be on or off.) Second, select the entire two-line design you have just created. Third, choose "Snap to Grid" from the shortcut menu. All knots will jump to their nearest grid points.
Straighten

During the design process you might inadvertently cause lines that were originally straight to move out of alignment. You might also find that lines that appeared perfectly horizontal or vertical at one zoom level are slightly out of alignment at another zoom level. In these situations the Straighten command can help.

Let’s experiment with this now. Draw a rectangle on your screen. Move the top left corner knot a very small amount so that the rectangle is out of alignment, as in the one pictured to the right. Select the entire rectangle, then choose “Straighten” from the Modify menu. The rectangle will be adjusted so that its lines are perfectly horizontal and vertical.

If the rectangle did not straighten, it could be that your lines are not close enough to being horizontal or vertical. By default, Straighten works on lines that are within $1^\circ$ of a true horizontal or vertical line. If you’d like a different tolerance, choose “Units and Precision” from the View menu and change the value called “Straighten precision.” Alternatively, you could move the top-left corner knot to make the lines closer to horizontal and vertical, and then Straighten again.

There’s another way to use the Straighten command that applies to a single line only. Try it by drawing a slightly curving line like the one pictured here. Select the entire line by double-clicking on it and then choose the Straighten command. The knots along the line will be moved so that the entire line is now straight.

Close this design without saving it.
Lamp Wizard

If you've ever attempted to design your own panel lamp, you soon discovered that the mathematical calculations required to determine the size of each individual panel can be daunting. Rather than dusting off your high school trigonometry, let Lamp Wizard do those calculations for you!

Start a new design, then use the "Lamp Wizard" command on the Draw menu. (If you aren't yet licensed to use the Lamp Wizard then you'll see a message informing you of your upgrade options and letting you know the limits of this feature; click "Proceed" to continue.) You'll see this dialog box:

Most of the controls are self-explanatory. Have some fun changing the values and watching the effect on the lamp image. Use your mouse to turn the image and see it from all sides: just position the mouse over the image, hold down the left mouse button, and move the mouse.
The control named "Diameter measurements" requires some explanation. When specifying the lamp diameters at each tier, you can express those measurements in terms of an outside diameter or an inside diameter. The diagram shows the two methods for a five-sided lamp. Choose whichever method is more suitable for your lamp before entering your measurements.

Instead of entering diameters as numeric values, you might instead prefer to specify the shape of your lamp by drawing a profile. Let's try this now. Click the "Cancel" button on the Lamp Wizard to return to a blank design. Use the Curve tool to draw a figure something like the black curve that appears in the box below, and then turn on the crosshairs and position a vertical crosshair to the right of it to specify the position of the central axis. Now select the entire line using "Select All" on the Edit menu and start the Lamp Wizard again. This time the shape of the lamp is based on your profile. You may now choose the number of sides for the lamp or make other adjustments.

If you're licensed to use the Lamp Wizard, you can position your mouse over a panel to see its dimensions in the "Panel measurements" area. You can also click the OK button to generate a Glass Eye 2000 drawing of the panels. Click the "Cancel" button on the Lamp Wizard to conclude this lesson.
Lesson 19: Multiple Designs and Views

In this lesson you’ll learn how to edit with multiple designs and multiple views. This lesson is not essential and can be skipped if you wish to jump ahead to the last lesson.

You can edit more than one design at a time, and you can even edit using more than one view of a single design. Let’s see how this works.

Before we get started, close any open design by choosing "Close" from the File menu. Continue closing designs until "Close" no longer appears on the File menu. After this your main window should show no design at all.

- Multiple designs

Open the "Flag" file again. Now without closing that file, open the "Mushroom" file. The flag disappears, and you see the mushroom. But what happened to the flag?

What has happened is that both designs are loaded but you are currently seeing only one of them. Click on "Window" in the menu bar and you’ll see the menu shown here. At the bottom of the menu we see the two file names: Flag and Mushroom. The check mark next to "Mushroom" tells you that you are currently viewing the design of that name. Now click on "Flag" and the view of the flag appears. Bring up the Window menu again and click on "Mushroom" and the view of the mushroom returns. When editing multiple designs you can edit in either view, switching back and forth as you please.
You can even see multiple designs simultaneously, which can be useful for comparing designs or for cutting and pasting between designs. Choose "Cascade" from the Window menu. The designs now appear in small windows within the main window, one hiding behind the other. Try dragging the title bar (the top of the window where the design name appears) to move a window, or try resizing a window. Whichever view you click on becomes the active view, and is available for editing. If views overlap, the active view is always on top. Watch how the color palette changes as you click in the windows: the palette always shows the colors for the active view.

Now choose "Tile" from the Window menu. The two views are shown side by side. Try zooming and panning each view, remembering first to click in the view you want to be active.

There is no menu command to return to single-view editing because you can do it with a single click. Look at the triplet of buttons at the top right corner of each view. Clicking the middle button "maximizes" that view to full size. Try this now by clicking the maximize button of either view. You are now back to single-view editing for that design.

The triplet of buttons for that view now appears in the top right corner of the application, as shown here. Don't confuse that triplet with the resize/close buttons for the main window that appears right above it!
The middle button now serves to "restore" the window to its smaller shape. Try clicking the restore button now.

- **Multiple views of a single design**

In addition to editing multiple designs simultaneously, you can also edit with multiple views of the same design. We will do this now.

Close the mushroom design. You can do this by making it the active view and then choosing "Close" from the File menu. You can also do this by clicking the "X" button at the top right of its view.

You are now left with the flag design. Choose "New View" from the Window menu. You now have another view of the flag. It is important to understand that you have two views on the same design—think of it as similar to having two photographs of the same person from (potentially) two different angles.

Choose "Tile" from the Window menu to place these windows side by side. Do a Zoom All in each view. (Remember that the Enter key performs a Zoom All.)

By this time you might be wondering what is useful about having two views of the same design. In truth this is a rarely-used feature, but let’s see one potential application. In the left-hand view, make sure that color is showing and that hairlines and knots are not shown. In the right-hand view, make sure that color is not shown and that hairlines and knots are showing. Now zoom the right-hand view so that the star fills the view.

You now have two very different views. The view on the left shows you a realistic rendering of the flag: you see the whole flag, with color, with thick lines, and without knots. The view on the right shows you a view more suitable to pattern editing: no color, with hairlines and knots showing. In the right-hand view, drag one of the knots. You will see the change reflected in both views as you drag. Experiment with different changes in the right view, or even switch and make changes in the left view.
The purpose of this is that you might find it easier to edit a design when the view properties are set as they are in the right-hand view, but you might prefer to see the design as it appears on the left. With multiple-view editing, you can have both.

Close the flag design without saving any changes.
Lesson 20: Putting It All Together

Even after working through all the previous lessons you might still be wondering how to use Glass Eye 2000 to construct a complete stained glass window design. In this lesson we will make a design from start to finish, illustrating many of the tools. This example should help to make clear what sort of process to go through to create a design.

Suppose you made the following sketch:

Now you want to make a Glass Eye design from this sketch, but you don’t have a scanner. Here is one way you might proceed. Follow along, and by the end of this lesson you will have drawn the entire pattern.

Start a new design, and be sure that the Sticky property is on. Choose "Units and Precision" from the View menu and choose design measurement units in inches, with a display format in fractions and a precision of 1/8".
Choose "Rectangle" from the Draw menu, then choose "Corner, Dimensions" from the shortcut menu as the drawing method. Now draw a rectangle in the view, approximately the shape of the outer edge of our sketch. We know we want the design to measure 36" x 16", so let's dimension the rectangle right away. Choose "Resize All" from the shortcut menu and resize the rectangle to a width of 36" and a height of 16".

Once this is done, the rectangle is now probably much larger than before; in fact, it has probably grown outside the area currently visible in your view. Do a Zoom All (the Enter key) to show the whole rectangle once again.

Now is a good time to enable Show Hairlines (if it was not already). Hairlines are drawn faster and are often easier to see than thick lines.

Looking at our sketch again, we need about a 1" border inside the outer edge of the design. We will use the grid to help make this precise. Turn on Auto Grid Snap. (Don't just show the grid; be sure the Auto Grid Snap button is pressed in.) Now use View Properties (on the View menu) to make sure we have horizontal and vertical spacing each set to 1". Click OK when ready. We now need the grid to line up exactly with the rectangle we have just drawn, so choose "Set Ruler Origin" from the View menu and click on the knot at the bottom left corner. There is always a grid point at the ruler origin, and since grid lines are spaced at even 1" intervals our rectangle and the grid line up exactly.

Turn rulers on by clicking the Show Rulers toolbar button. The rulers will show you that your design is indeed 36" x 16". You can turn the rulers off and on as you like during this lesson. Having them off for now is probably the best choice as it leaves the view less cluttered.

Now draw the inner rectangle. Use the grid to make a second rectangle exactly 1" inside the first. Automatic grid snapping makes it easy to be precise. After drawing, return to Pick mode. Your design should now look like what is shown on the next page.
We now want to place the ellipse in the center, and the grid will help with this too. Having a mark to indicate the halfway point between the left and right ends of the design will be helpful, so let’s use the Subdivide command for this.

Select the topmost horizontal line of the inner rectangle and then choose "Subdivide" from the shortcut menu. For the number of subdivisions, enter 2 and then click OK. The new knot is now exactly halfway across the design.

Now choose "Ellipse" from the Draw menu. Bring up the shortcut menu and choose "Center, Dimensions" as your drawing method. Using the knot you just added as a guide, click on the grid point at the very center of your design. (You can probably judge the vertical halfway point using the grid marks alone. Another way to locate the center is to find the point 18", 8" by reading the fields at the right end of the status bar.) Next, make an ellipse like the one on the next page by clicking with the mouse about four inches to the right of the knot you just added with the Subdivide command; this would be at location 22", 15". If the ellipse does not look like what you see on the next page, click Undo and try again.
We can take advantage of the horizontal symmetry in this design. For most of our remaining work, we will add to only the left side and later reflect that work onto the right.

Now add the short lines that lie between the two rectangles. We need only add to the ones on the left and down the center:

We'll now work on the three-pointed pattern in the lower left corner of the window. Turn off the grid and zoom in on that corner—the best way is to enter Zoom mode and then drag a zoom box around the area of interest. There is a diagonal line of symmetry in that pattern, so let's design half of it and then reflect to get the other half.
Turn on the diagonal crosshairs. Enter Pick mode and position one of the crosshairs over one of the corner knots as shown. Be sure you release the mouse button when the pointer is directly over one of the corner knots or the crosshair may not be positioned perfectly.

Now draw three curves to create one half of the corner pattern. Don’t worry about making your pattern look exactly like the one pictured.
Select the three curves you have just drawn, choose "Reflect" from the shortcut menu, and choose "Across /" as the reflection method. After you have done this, unselect the lines (just click in the view where no lines are nearby) and then turn off crosshairs.

Do a Zoom All by pressing the Enter key.

Now is a good time to save the work you have done so far. Click the Save button, type a name of your choice for this design, then click "Save."

Now add the following curve:
Next add two straight lines using the Curve command.

Again, it doesn’t matter if your lines look somewhat different from the ones shown here.

Now you can reflect your work on the left half of the design over to the right. Turn on horizontal/vertical crosshairs, enter Pick mode, and drag the vertical crosshair to the knot at the top of the ellipse. (If you don’t see the vertical crosshair, use the Set Crosshairs Origin command on the View menu.) Then drag out a select box as follows:
Choose "Reflect" from the shortcut menu, and choose "Across |" as the reflection method. After you have done this, unselect lines and turn off the crosshairs. You now have the following design:

![Design Image](image)

Only one more line to go! Draw the final curve now. You can draw this the usual way—no need to bother with reflecting. Don't add any knots but just use the existing ones.

![Final Design Image](image)
To be able to color you will have to add knots at the points where this new curve crosses two other curves. Use the Add Knot command to add those knots now:

Now turn off hairlines and turn off knots. Select all lines in the design (pressing Ctrl+A is one way to do it) and choose "Line Properties" from the shortcut menu. Choose a lead width of ¼". Your pattern should now look like this:
You can experiment with other lead widths if you like.

Now let's color the design. Click on a color you like for the border pieces (if you don't see one you like on the color palette, double-click one of the buttons and choose a color using the Color Selector dialog box), and then drag a color box around the entire design. This colors the pieces in the border, but then it colors every piece in the window! You can now assign different colors to the non-border pieces. Choose glass or textured color as you wish.

You should be able to color all pieces in this window. If you cannot color a piece, use the Suggest command on the Help menu to determine what the problem is. If you get a suggestion about a missing knot at the top of the ellipse, you can probably ignore it: the lines might cross a little as they approach the knot, but the program should be able to sort that out.

Choose "Page Setup" from the File menu, and in the Page Setup dialog box choose a Format of "All on one page" and an orientation of "Landscape." Click OK. Now click on the Print Preview toolbar button to see how the design will look when printed. If you are satisfied with its appearance, click the Print button to print the page.

Close this design and save your changes. Your design is saved using the name you gave it earlier.

Congratulations! You've have completed all twenty lessons. By now you should be quite proficient in using Glass Eye 2000. Now go forward and create beautiful designs of your own.
V. COMMAND SUMMARY

- **About Glass Eye 2000 command (Help menu)**
  Displays your product version number and copyright notice.

- **Acquire TWAIN Image (File menu)**
  Allows you to import a background image from a TWAIN device. Use the "Select TWAIN Source" command to choose from among multiple devices.

- **Add Background command (File menu)**
  Lets you add a background image to your design. After the image is imported it can be manipulated with the Background Properties command.

- **Add Knot mode (Edit menu)**
  Lets you add a knot to an existing line. If the knot is added at the intersection of multiple lines, the new knot belongs to each line. If the knot is added on top of a slider, then a fixed knot will replace that slider. Adding a knot to a line sometimes causes that line to change its shape slightly. This is normal. A new knot will sometimes merge with nearby knots and lines. To reduce the area of influence, zoom in before adding the new knot.

- **Add Text mode (Text menu)**
  Allows you to add text in two steps: pick a position for the text with the mouse, then enter the text itself. While entering the text you can specify its attributes, such as its font or color.

- **Arc mode (Draw menu)**
  Lets you draw an arc in your design. Click in the view to place the knots. The arc must go through exactly three knots.
- **Auto Grid Snap command (View Properties dialog box)**
  Causes knots to snap to grid points when created or moved.

- **AutoSave command (File menu)**
  Use this command to have your design saved at regular intervals. You can specify how often to save, and whether the save should happen automatically or with a confirmation.

- **AutoTrace Background command (Draw menu)**
  Detects lines in your background image and converts them to curves and arcs. You must have a background image in your design for this command to be enabled.

- **AutoTrace Text command (Text menu)**
  Draws an outline around each letter of a text element created with the Add Text command. Once your letters have been drawn as lines and curves, you'll have the ability to resize them, rotate them, color them, and so on.

- **Background Properties command (File menu)**
  Allows you to view and change various properties of the background image.

- **Break command (Modify menu)**
  Allows you to break one line into two or more lines. With a knot selected, any line going through that knot will be separated into two adjacent lines, with each line terminating at that knot. With a line segment selected, you separate a discontinuous line into a set of unconnected continuous lines.

- **Browse Designs / Browse Bevels command (File menu)**
  Allows you to browse through a library of designs or bevels.
- **Cascade command (Window menu)**
  Arranges views in reduced-size, overlapping windows.

- **Change Font command (Text menu)**
  Allows you to set font attributes for the selected text. If no text is selected, this appears as the "Set Default Font" command and allows you to set font attributes for the text you will later add to your design.

- **Circle mode (Draw menu)**
  Lets you draw a circle in your design. The circle is created as an arc going through four knots. Use the shortcut menu to choose either of these drawing methods:

  - Center, Radius: Define the circle by clicking first at its center and then at a point on the circle.
  - Frame: Define the circle by clicking twice to define a square frame into which the circle fits.

- **Close command (File menu)**
  Closes all views containing the active design. If you have made changes to the design, you will be asked if you want to save changes before you close. If you close a design without saving, you lose all changes made since the last time you saved it. Before closing an untitled design, Glass Eye 2000 displays the Save As dialog box and suggests that you name and save the design.

- **Close command (window pop-up menu)**
  Closes the application, a view, or a dialog box.

  Double-clicking the small icon in the top left of a window is the same as choosing the Close command from that window’s pop-up menu.
■ **Color mode (Edit menu)**

Lets you click on a piece to change its color to the working color. A click with the right mouse button changes the piece clicked on as well as all other pieces of that color. A left mouse button click with the Shift key held down causes the color of the area clicked to become the working color.

■ **Color Options command (View menu, Ctrl+L)**

Lets you choose among three ways of showing the glass in your design: you can stretch glass to fit each piece, display glass at its actual size, or use a solid color approximation. You also have tools for manipulating the color palette and the option to highlight pieces when coloring or numbering.

■ **Copy command (Edit menu, Ctrl+C)**

Copies selected line sections onto the Clipboard. Pieces (colors) are also placed on the Clipboard if all bordering line sections are selected. Copying to the Clipboard replaces the contents previously stored there.

■ **Curve mode (Draw menu)**

Lets you draw a curve in your design. Click in the view to place the knots; double-click to end the line.

■ **Customize Menus and Hot Keys command (View menu)**

Allows you to customize the context-sensitive "shortcut" menu that appears when you click the right mouse button in your design view.

■ **Cut command (Edit menu, Ctrl+X)**

Removes the selected line sections and text from the design and puts them on the Clipboard. Pieces (colors) are also placed on the Clipboard if all bordering line sections are selected. Selected knots are deleted. Cutting to the Clipboard replaces the contents previously stored there.
Default Line Properties command (Modify menu)
Lets you change the properties used for all subsequent line drawing.

Delete command (Edit menu, Del)
Removes the selected line sections, text, and knots from the design.

Do I Have the Latest Version? command (Help menu)
Takes you to the Dragonfly Software web site to see if any free updates are available. Establish your Internet connection before using this command.

Drawing Properties command (Draw menu)
Here you can choose the drawing methods for squares, rectangles, circles, ellipses, and polygons. You can also specify how Shift key locking works during line drawing and moving.

Edit Text mode (Text menu)
Allows you to change the content or the attributes of the selected text.

Ellipse mode (Draw menu)
Lets you draw an ellipse. The ellipse is created as an arc going through four knots. Use the shortcut menu to choose either of these drawing methods:

  Center, Dimensions: Define the ellipse by clicking first at its center and then at another point to specify the width and height.

  Frame: Define the ellipse by clicking twice to define a rectangular frame into which the ellipse fits.

English / Deutsch / Español / Français / Italiano (Language menu)
Have Glass Eye 2000 operate in your chosen language.
- **Enter License Key or Registration Number command (Registration menu)**
  Use this command to activate your product license by entering either a license key or a registration number. Your product reference code is also shown here.

- **Erase mode (Edit menu)**
  Allows you to delete parts of your design without first having to select them. In Erase mode hold down the left mouse button to erase lines and text, or accompany that with the Shift key to erase knots along the length of a line.

- **Exit command (File menu)**
  Ends your design session.

- **Explode command (File menu)**
  Separates the pieces of your design so that they can be printed, plotted, or cut. Exploding is a two-phase process: separating your design into a set of unconnected pieces, and nesting those pieces within plotter pages.

- **Export Design command (File menu)**
  Save your design in file formats other than the Glass Eye format.

- **Flip command (Modify menu)**
  Flips the selection from left to right (a horizontal flip) or from top to bottom (a vertical flip).

- **Glass Eye 2000 Help command (Help menu, F1)**
  Displays the Help Topics dialog box.

- **Glass Orientation mode (Edit menu)**
  Lets you change the position and rotation of glass within a piece. Hold down the Ctrl key to affect all pieces of the same color.
■ **Group command (Modify menu, Ctrl+G)**

 Allows you to group a set of lines. When formed into a group, selecting one of the lines in the group will select all lines in the group.

■ **How Much Does It Cost? command (Registration menu)**

 Tells you the price to purchase or upgrade Glass Eye 2000. Prices are subject to change, so please visit www.dfly.com to confirm the prices shown.

■ **Import Design command (File menu)**

 Open a file that was saved in WMF, EMF, DXF, or DWG format.

■ **Insert command (File menu)**

 This command functions like the Open command, except that instead of opening the design into a new view the design is added at the center of the active view.

■ **Join Lines command (Modify menu)**

 Forms one line out of two selected, adjacent lines.

■ **Lamp Wizard command (Draw menu)**

 Allows you to enter the dimensions of a panel lamp shade and visualize it in an interactive 3D viewer. It can show you the dimensions of each panel and can generate the outlines of those panels for you to use as a template for construction.

■ **Line Properties command (Modify menu)**

 Lets you change the lead size and color of the selected line sections. A lead size consists of a face width, which is the width of the visible lead in your window, and a heart thickness, which is the width of the lead that sits directly between pieces of glass.
■ Make Frame command (Modify menu)  
Converting the border of your design from H-came to U-came.

■ Maximize command (window pop-up menu)  
Enlarges the window to fill the available space.

■ Minimize command (application window pop-up menu)  
Reduces the Glass Eye 2000 window to a button on the Windows taskbar.

■ Move command (Modify menu)  
Lets you move or copy the selection by specified horizontal and vertical distances.

■ Move command (window pop-up menu)  
Allows you to move the active window or dialog box with the arrow keys. This command is unavailable if the window is maximized.

■ New command (File menu, Ctrl+N)  
Creates a new, blank design. If you wish to open an existing design, use the Open command.

■ New View command (Window menu)  
Opens a new view with the same design as the active view. You can open multiple views to display different views of a design at the same time. If you change the contents in one view, all other views containing the same design reflect those changes. When you open a new view, it becomes the active view and is displayed on top of all other views.
- **Next command (view pop-up menu, Ctrl+Tab)**
  Switches to the next open view. Glass Eye 2000 determines which view is next according to the order in which you opened the views.

- **Nudge Up/Down/Left/Right command (Arrow keys)**
  Moves the selection a small amount in the direction of the arrow key pressed. If the Ctrl key is held down while pressing the arrow key, the amount moved is very slight.

- **Offset command (Draw menu)**
  Draws an offset line on the insides of pieces, or around the outside of your design.

- **Open command (File menu, Ctrl+O)**
  Opens an existing design in a new view. If you wish to begin a new design, use the New command. You can have multiple designs open simultaneously. Use the Window menu to switch among the multiple open designs.

- **Page Setup command (File menu)**
  Lets you choose options for printing, including format (all on one page, actual size, or print-to-scale), reversed design, paper size and source, orientation (portrait or landscape), and margins. Click the "Calibrate" button if you want Glass Eye 2000 to compensate for printer inaccuracies.

- **Pan mode (View menu)**
  Lets you scroll the view by dragging any point in it.

- **Park License on Server (Registration menu)**
  Stores your product license on the Dragonfly Software server for later retrieval using the Retrieve License from Server command.
- **Paste command** (Edit menu, Ctrl+V) ![Paste](image)

  Inserts a copy of the Clipboard contents at the crosshairs origin (if visible) or at the center of the view.

- **Pick mode** (Edit menu) ![Pick](image)

  Lets you select knots, text, and line sections by clicking on them. Also lets you move these elements by dragging them.

- **Piece Labeling command** (Text menu)

  Use this command to control how pieces are labeled with color codes and numbers.

- **Piece Picker mode** (Edit menu) ![Picker](image)  

  Lets you easily select, move, and rotate pieces that have been separated using the Explode command.

- **Plot command** (File menu) ![Plot](image)  

  Similar to the Print command, but instead of sending a design to your printer you are sending it to your plotter or cutting device. Glass Eye 2000 uses the term "plot" to include both plotting and cutting.

- **Polygon mode** (Draw menu)

  Lets you add a polygon to your design. The number of sides is specified using the Drawing Properties command. A polygon is always drawn with two clicks: one at the center, and one at a corner.

- **Previous command** (Ctrl+Shift+Tab)

  Switches to the previous open view. Glass Eye 2000 determines which view is previous according to the order in which you opened the views.
Print command (File menu, Ctrl+P)

Lets you print a design. This command presents the Print dialog box, where you may specify the destination printer, the range of pages to be printed, the number of copies, and other printer setup options. Clicking the "Properties" button on the Print dialog box will take you to another dialog box that gives you extra control over your printed output, such as graphics resolution (sometimes called "print quality") and color adjustments. Before printing, be sure to have set your desired print options using Page Setup. Use Print Preview to see how the design will appear when printed.

Print Preview command (File menu)

Displays the design as it would appear when printed. When you choose this command, the main window will be replaced with a print preview window in which pages will be displayed in their printed format. The print preview toolbar offers you options to view either one or two pages at a time, move back and forth through the pages, zoom in and out, and initiate printing.

Properties command (File menu)

This command brings up the Properties dialog box, which contains three tabbed pages. The General page allows you to specify a title, artist, style, category, shape, difficulty, keywords, and notes for any design. The Glass Usage page shows you your glass usage and costs. The Came Usage page shows you your usage and costs for lead, zinc, or brass came. The Miscellaneous page lists materials other than glass or came required to construct your design. The Construction Cost page provides a spreadsheet for you to compute the construction cost or retail price of a design.

Purchase Glass Eye 2000 command (Registration menu)

Use this command to purchase your copy of Glass Eye 2000. Purchases are typically transacted over the Internet, but options to order by telephone or mail are available.
• Rectangle mode (Draw menu)
Lets you draw a rectangle in your design. The rectangle is created as four connected curves. Use the shortcut menu to choose either of these drawing methods:

Center, Dimensions: Define the rectangle by clicking first at its center and then at a corner to specify the width and height.

Corner, Dimensions: Define the rectangle by clicking at two opposing corners.

• Redo command (Edit menu, Ctrl+Y)  
Reverses the action of the Undo command.

• Redraw command (View menu, F5)
Erases the view and redraws the design.

• Reflect command (Modify menu)
Makes a mirror image of the selection across one or both of the crosshairs. This command is available only when crosshairs are shown.

• Remove Frame command (Modify menu)  Pro Pro Plus Enterprise
Converts the border of your design from U-came to H-came.

• Remove License command (Registration menu)
This command will erase your product license. Use with extreme caution.

• Repeat command (Modify menu)  Pro Pro Plus Enterprise
Lets you make multiple copies of a selected element in your design.
- **Resize command (Modify menu)**
  Lets you specify the width and height of the selection. Both width and height are measured from the middle of lead lines, not the outer edges.

- **Restore command (window pop-up menu)**
  Returns a maximized window to its previous size.

- **Retrieve License from Server command (Registration menu)**
  Retrieves a product license that was parked on the Dragonfly Software server using the Park License on Server command.

- **Rotate mode (Modify menu)**
  Lets you rotate the selection using your mouse or keyboard.

- **Save command (File menu, Ctrl+S)**
  Saves the active design using its current filename and folder. When you save a design for the first time, Glass Eye 2000 displays a dialog box so that you can name your file and choose its folder. If you want to change your file's name or folder, use the Save As command.

- **Save As command (File menu)**
  Lets you name and save the active design. To save a design using its current name and folder, use the Save command.

- **Scale command (Modify menu)**
  Lets you scale the selection by specified horizontal and vertical scale factors.

- **Select All command (Edit menu, Ctrl+A)**
  Selects all lines and text in the design.
Select All Text command (Text menu)
Selects all the text in your design. This does not include piece labels, which are not selectable.

Select Similar Lines command (Edit menu)
Selects lines that share the same face width, heart thickness, or color.

Send Design via Email command (File menu)
Sends the design through electronic mail as an attachment. The attached file can be in .eye format or a number of image file formats.

Set Crosshairs Origin command (View menu)
Lets you click in the view to set the point where the crosshairs intersect.

Set Crosshairs Origin to Ruler Origin command (Ctrl+0)
Sets the point where the crosshairs intersect to the (0,0) point of the rulers.

Set Knot Location command (Modify menu)
 Lets you type in the location for a selected knot.

Set Ruler Origin command (View menu)
Lets you click in the view to set the (0,0) point of the rulers.

Set Ruler Origin to Crosshairs Origin command (Ctrl+Shift+0)
Sets the (0,0) point of the rulers to the point where the crosshairs intersect.

Show Background command (View Properties dialog box, Ctrl+B)
Displays or hides the background image.
■ **Show Colors command** *(View Properties dialog box)*
Displays or hides the colors of pieces.

■ **Show Crosshairs command** *(View Properties dialog box)*
Displays or hides the horizontal/vertical or diagonal crosshairs.

■ **Show Grid command** *(View Properties dialog box)*
Displays or hides grid lines. If the grid line density becomes too great then grid lines are not shown.

■ **Show Hairlines command** *(View Properties dialog box)*
Causes lines to be shown or not shown as hairlines.

■ **Show Knots command** *(View Properties dialog box)*
Displays or hides knots.

■ **Show Rulers command** *(View Properties dialog box)*
Displays or hides rulers.

■ **Size command** *(window pop-up menu)*
Allows you to size the active window with the arrow keys.

After the pointer changes to the four-headed arrow:

1. Press an arrow key to move the pointer to the border you want to move.
2. Press an arrow key to move the border.
3. Press Enter when the window is the size you want.

This command is unavailable if the window is maximized.
■ Snap to Grid command (Modify menu)
Moves all selected knots (or knots adjacent to selected line sections) to their nearest grid points.

■ Square mode (Draw menu)
Lets you draw a square in your design. The square is created as four connected curves. Use the shortcut menu to choose either of these drawing methods:
- Center, Side: Define the square by clicking first at its center and then at another point to specify the size.
- Corner, Side: Define the square by clicking first at one of its corners and then at another point to specify the size.

■ Status Bar command (View menu)
Displays or hides the status bar, which describes the action to be executed by the selected menu item or toolbar button, and which displays the pointer location.

■ Sticky command (View properties dialog box)
When this option is enabled, knots that are created or moved will automatically join with other knots or become sliders on lines. Only in rare circumstances should you disable this option.

■ Straighten command (Modify menu)
Brings selected lines into horizontal or vertical alignment. This command can also arrange the knots of a single curve or arc into a straight line defined by its endpoints.
- **Stretch mode (Modify menu)**
  Causes a stretch box to appear around the selection. You can then change the size of the selection by dragging one of the resize handles on the box. If the Shift key is held down the selection maintains its proportions; if the Ctrl key is held down the selection maintains its center. You can also move the selection by dragging the inside of the box.

- **Subdivide command (Modify menu)**
  Lets you divide the selected line sections into smaller sections of equal length.

- **Suggest command (Help menu, Ctrl+Q)**
  Looks for design flaws in the active view and offers suggestions for fixing them.

- **Tile command (Window menu)**
  Arranges views in reduced-size, non-overlapping windows.

- **Toggle Between Commands command (Spacebar)**
  Switches between the last two command modes.

- **Toolbar command (View menu, Ctrl+T)**
  Displays or hides the toolbar, which contains buttons for the most common commands.

- **Transfer License command (Registration menu)**
  Use this command to move your product license to another computer. After doing so, Glass Eye 2000 will become disabled on the original computer.
Tutorial command (Help menu)
Looks on your computer for Glass Eye 2000 lessons that you can see in your web browser. If not found on your computer, you have the option of finding the lessons on the Dragonfly Software web site.

Undo command (Edit menu, Ctrl+Z)
Reverses the last editing action, if possible.

Ungroup command (Modify menu, Ctrl+U)
Reverses the action of the Group command.

Units and Precision command (View menu)
Lets you set the way measurements and materials usage are displayed. You can set units (inches, feet, millimeters, centimeters, or meters), format (decimals or fractions), and precision values, including those that determine the accuracy of the Rotate and Straighten commands.

Unselect All command (shortcut menu)
Causes no line sections, text, or knots to be selected.

Upgrade Glass Eye 2000 command (Registration menu)
Allows you to upgrade to a more advanced version of Glass Eye 2000.

View Log command (Registration menu)
Shows you a history of registration events. Do not delete or modify the log. The log can be useful if you need to contact Dragonfly Software technical support regarding a licensing issue.
View Properties command (View menu, Ctrl+E)
Lets you set many properties of the active view. Changes here affect the way a design is viewed, but do not affect the design itself.

Visit the Discussion Group command (Help menu)
This command will take you to the Yahoo! Group for Glass Eye 2000. There you can ask questions, chat, share designs, and see our events calendar.

What’s This? command (Help menu, Shift+F1)
Provides help on some portion of Glass Eye 2000. After initiating the command, the pointer changes to an arrow and question mark. Then click somewhere in the Glass Eye 2000 window, or choose a menu item, or press a key. A help topic will be shown for what you have chosen.

Yank mode (Edit menu)
Lets you drag a line section away from a knot. To yank, place the pointer on a line section near a knot and then drag.

Zoom mode (View menu)
Lets you control how large or small a design appears in a view. You can click with the left mouse button to zoom in or with the right mouse button to zoom out. You can also drag a zoom box around the portion of the design you want to fill the view.

Zoom All command (View menu, Enter)
Displays the entire design in the view.

Zoom In command (View menu, +)
Makes the design appear larger in the view. With the Ctrl key held down the amount of zoom is reduced to 1/10 of the normal amount.
• Zoom Out command (View menu, –)
Makes the design appear smaller in the view. With the Ctrl key held down
the amount of zoom is reduced to 1/10 of the normal amount.

• 1, 2, … command (Window menu)
At the bottom of the Window menu is a list of currently open views. A check
mark appears in front of the design name of the active view. Choose a design
from this list to make its view active.

• 1, 2, 3, 4 command (File menu)
Opens the design you select from the numbered list of designs. The last nine
designs you have accessed are shown.
## VI. KEYBOARD COMMANDS

<table>
<thead>
<tr>
<th>Key</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Glass Eye 2000 Help</td>
</tr>
<tr>
<td>Shift + F1</td>
<td>What's This?</td>
</tr>
<tr>
<td>F5</td>
<td>Redraw</td>
</tr>
<tr>
<td>Enter</td>
<td>Zoom All</td>
</tr>
<tr>
<td>Escape</td>
<td>Cancel the current operation</td>
</tr>
<tr>
<td>+</td>
<td>Zoom In</td>
</tr>
<tr>
<td>–</td>
<td>Zoom Out</td>
</tr>
<tr>
<td>Del</td>
<td>Delete</td>
</tr>
<tr>
<td>Up Arrow</td>
<td>Nudge Up</td>
</tr>
<tr>
<td>Down Arrow</td>
<td>Nudge Down</td>
</tr>
<tr>
<td>Left Arrow</td>
<td>Nudge Left (or rotate counterclockwise in Glass Orientation mode)</td>
</tr>
<tr>
<td>Right Arrow</td>
<td>Nudge Right (or rotate clockwise in Glass Orientation mode)</td>
</tr>
<tr>
<td>Spacebar</td>
<td>Toggle Between Commands</td>
</tr>
<tr>
<td>Mouse wheel held down</td>
<td>Pan</td>
</tr>
<tr>
<td>Page Up</td>
<td>Scroll up</td>
</tr>
<tr>
<td>Shift + Up Arrow</td>
<td>Scroll up</td>
</tr>
<tr>
<td>Page Down</td>
<td>Scroll down</td>
</tr>
<tr>
<td>Shift + Down Arrow</td>
<td>Scroll down</td>
</tr>
<tr>
<td>Page Left</td>
<td>Scroll left</td>
</tr>
<tr>
<td>Shift + Left Arrow</td>
<td>Scroll left</td>
</tr>
<tr>
<td>Page Right</td>
<td>Scroll right</td>
</tr>
<tr>
<td>Shift + Right Arrow</td>
<td>Scroll right</td>
</tr>
<tr>
<td>Alt + Up Arrow</td>
<td>Rotate clockwise</td>
</tr>
<tr>
<td>Shift + mouse wheel backward</td>
<td>Rotate clockwise</td>
</tr>
<tr>
<td>Alt + Down Arrow</td>
<td>Rotate counterclockwise</td>
</tr>
<tr>
<td>Shift + mouse wheel forward</td>
<td>Rotate counterclockwise</td>
</tr>
<tr>
<td>Mouse wheel forward/backward</td>
<td>User-defined at Units and Precision</td>
</tr>
</tbody>
</table>

Continued on the next page…
<table>
<thead>
<tr>
<th>Keyboard Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + A</td>
<td>Select All</td>
</tr>
<tr>
<td>Ctrl + B</td>
<td>Show Background</td>
</tr>
<tr>
<td>Ctrl + C</td>
<td>Copy</td>
</tr>
<tr>
<td>Ctrl + E</td>
<td>View Properties</td>
</tr>
<tr>
<td>Ctrl + G</td>
<td>Group</td>
</tr>
<tr>
<td>Ctrl + L</td>
<td>Color Options</td>
</tr>
<tr>
<td>Ctrl + N</td>
<td>New</td>
</tr>
<tr>
<td>Ctrl + O</td>
<td>Open</td>
</tr>
<tr>
<td>Ctrl + P</td>
<td>Print</td>
</tr>
<tr>
<td>Ctrl + Q</td>
<td>Suggest</td>
</tr>
<tr>
<td>Ctrl + S</td>
<td>Save</td>
</tr>
<tr>
<td>Ctrl + T</td>
<td>Toolbar</td>
</tr>
<tr>
<td>Ctrl + U</td>
<td>Ungroup</td>
</tr>
<tr>
<td>Ctrl + V</td>
<td>Paste</td>
</tr>
<tr>
<td>Ctrl + X</td>
<td>Cut</td>
</tr>
<tr>
<td>Ctrl + Y</td>
<td>Redo</td>
</tr>
<tr>
<td>Mouse small thumb button</td>
<td></td>
</tr>
<tr>
<td>Ctrl + Z</td>
<td>Undo</td>
</tr>
<tr>
<td>Mouse large thumb button</td>
<td></td>
</tr>
<tr>
<td>Ctrl + 0</td>
<td>Set Crosshairs Origin to Ruler Origin</td>
</tr>
<tr>
<td>Ctrl + Shift + 0</td>
<td>Set Ruler Origin to Crosshairs Origin</td>
</tr>
<tr>
<td>Ctrl + Tab</td>
<td>Next</td>
</tr>
<tr>
<td>Ctrl + F6</td>
<td></td>
</tr>
<tr>
<td>Ctrl + Shift + Tab</td>
<td>Previous</td>
</tr>
<tr>
<td>Ctrl + Shift + F6</td>
<td></td>
</tr>
</tbody>
</table>
VII. HSL & RGB

This chapter needs to be read only by those users who wish to understand the use of the Hue, Sat, Lum and Red, Green, Blue fields in the Textured Color area of the Color Selector.

The Color Selector dialog box uses two models for specifying solid colors: the HSL model and the RGB model.
**HSL color model**

HSL stands for Hue, Saturation, and Luminosity. The Color Selector dialog box provides controls for specifying HSL values. The following illustration shows the spectrum and luminosity controls that appear in the dialog box and shows the ranges of values the user can specify with these controls:

![HSL color model diagram](image)

In the Color Selector dialog box, the saturation and luminosity values must be in the range 0 through 240, and the hue value must be in the range 0 through 239.

**RGB color model**

The RGB model is used to designate colors for displays and other devices that emit light. Valid red, green, and blue values are in the range 0 through 255, with 0 indicating minimum intensity and 255 indicating maximum intensity. The illustration on the next page shows how the primary colors red, green, and blue can be combined to produce four additional colors.
### Examples

Here are eight colors and their associated HSL and RGB values:

<table>
<thead>
<tr>
<th>Color</th>
<th>Hue</th>
<th>Sat</th>
<th>Lum</th>
<th>Red</th>
<th>Green</th>
<th>Blue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Red</td>
<td>0</td>
<td>240</td>
<td>120</td>
<td>255</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Yellow</td>
<td>40</td>
<td>240</td>
<td>120</td>
<td>255</td>
<td>255</td>
<td>0</td>
</tr>
<tr>
<td>Green</td>
<td>80</td>
<td>240</td>
<td>120</td>
<td>0</td>
<td>255</td>
<td>0</td>
</tr>
<tr>
<td>Cyan</td>
<td>120</td>
<td>240</td>
<td>120</td>
<td>0</td>
<td>255</td>
<td>255</td>
</tr>
<tr>
<td>Blue</td>
<td>160</td>
<td>240</td>
<td>120</td>
<td>0</td>
<td>0</td>
<td>255</td>
</tr>
<tr>
<td>Magenta</td>
<td>200</td>
<td>240</td>
<td>120</td>
<td>255</td>
<td>0</td>
<td>255</td>
</tr>
<tr>
<td>White</td>
<td>0</td>
<td>0</td>
<td>240</td>
<td>255</td>
<td>255</td>
<td>255</td>
</tr>
<tr>
<td>Black</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>
Choosing a solid or textured color

There are three ways to specify a color using the Textured Color area of the Color Selector dialog box:

1. Drag the pointer in the spectrum control to select hue and saturation values, then drag the pointer in the luminance bar to select brightness.

2. Enter hue, saturation, and luminosity (HSL) values by using the Hue, Sat, and Lum edit controls.

3. Enter red, green, and blue (RGB) values by using the Red, Green, and Blue edit controls.

The first of these is sufficient for nearly all users. The other two are provided mostly for those users who have HSL or RGB values for a particular color they wish to use in a design.
VIII. Glossary

■ Active design
The design that is currently visible and available for editing.

■ Active view
The view that contains the active design. If multiple views are visible, the active view is highlighted.

■ Arc
A line along a set of knots. Its shape is determined by one or more elliptical arcs.

■ Clipboard
The Clipboard is a special storage place for lines and pieces. Lines, pieces, and text can be placed onto the Clipboard with the Cut and Copy commands and copied from the Clipboard with the Paste command.

■ Color button
A button on the color palette. Click on a color button to make its color the working color. Double-click it to change the color.

■ Color code
A letter (or other symbols) that identify a color. The color code is associated with a design, so the same color can have a different code in different designs.

■ Color palette
The bar (or bars) on the edge of the view containing the color buttons.
Crosshair
A line used for the alignment of knots and the reflection of lines. Crosshairs appear either as a horizontal and a vertical line or as two diagonal lines.

Crosshairs origin
The place where the crosshairs meet.

Curve
A smooth line along a set of knots. Its shape is determined by a spline function.

Discontinuous line
A curve or arc with gaps in it. The line remains smooth, as if there were invisible sections in it.

Knot
A point along a line that is used to define the shape of that line and to define a place where lines connect.

License key
A code used to unlock Glass Eye 2000 for use on your computer.

Line
Either a curve or an arc. Except for some exceptional arcs, a line is always smooth.

Line section
The portion of a line that passes between two of its knots.
■ **Menu bar**
The area displayed across the top of the main window, directly below the title bar. The menu bar contains a row of menu titles.

■ **Piece**
A colorable region of a design. A piece is always surrounded by line sections.

■ **Ruler origin**
The point in a view that measures (0,0) on the rulers.

■ **Scroll arrow**
A button appearing at each end of a scroll bar.

■ **Scroll bar**
A rectangular control at the right and bottom of a view, enabling you to adjust what portions of the design are visible in the view.

■ **Scroll box**
A control on a scroll bar that indicates what portion of the design is visible in the view.

■ **Shortcut menu**
The menu that appears when you click the right mouse button.

■ **Slider**
A knot whose position is determined by the shape of a line. Sliders are white, whereas other knots are gray.
- **Status bar**
  The area displayed across the bottom of the main window that displays descriptive messages about a selected menu item or toolbar button. It also displays the horizontal and vertical position of the pointer.

- **Stretch box**
  A rectangle surrounding the selection. By dragging the resize handles on the box you can reshape the selection.

- **Title bar**
  The area displayed across the very top of the main window that displays "Glass Eye 2000" and also the file name of the active design.

- **Toolbar**
  A panel displayed across the top of the main window, directly below the menu bar. The toolbar contains a row of toolbar buttons.

- **Toolbar button**
  A button on the toolbar designed to provide quick access to a specific command or option.

- **View**
  The screen area in which a design is displayed.

- **Working color**
  The color you "paint" with as you assign color to pieces or color buttons.
IX. INDEX

Acquiring, 87, 143
Active design, 169
Active view, 169
Arcs, 102–5, 143, 169
AutoSave, 144
AutoTrace Background, 90–92, 144
AutoTrace Text, 77, 144
Backgrounds, 85–88, 157
Breaking lines, 106, 144
Browsing, 82–84, 144
Circles, 49, 145
Clipboard, 99, 169
Color, 40, 63–72, 146
  box, 64
  buttons, 40, 63–65, 169
  choosing, 64–67, 168
  codes, 67, 76, 169
  options, 70–71, 146
  orientation, 72, 148
  palette, 22, 40, 63, 64,
  71, 169
  removing, 63
  showing, 35, 157
  transparency, 73
Copying, 100, 146
Crosshairs, 93–95, 97, 156,
  157, 170
Curves, 9–10, 43–44, 102–3,
  146, 170
Cutting, 99, 146
Deleting, 38, 55, 100, 147
  Diagonal lines, 105
  Discontinuous lines, 106–7, 170
  Discussion group, 161
  Dragonfly Software, 7
  Drawing, 9–10
    arcs, 102–5, 143
    circles, 49, 145
    curves, 43–44, 102–3,
    146
    ellipses, 49, 147
    polygons, 51
    properties, 50–51, 147
    rectangles, 47–48, 154
    squares, 47–48, 158
Drawing surface color, 98
Ellipses, 49, 147
Erasing, 39, 148
Exploding, 148
Exporting, 89, 148
Face width, 41–43, 98
Files
  closing, 40, 145
  opening, 16, 151
  saving, 45, 155
Flipping, 116–17, 148
Framing, 150, 154
Grid lines, 95–96, 157, 158
Grouping, 149
Hairlines, 34, 42, 98, 157
Heart thickness, 41–43, 98
Help, 28–29, 148
Horizontal lines, 105, 115
Hot keys, 146

HSL color model, 165–66

Importing, 85–88, 149

Inserting, 149

Installing, 2

Intersecting lines, 56–57

Joining lines, 105–6, 149

Keyboard commands, 163

Knots, 9, 170

adding, 54–57, 143

deleting, 55

moving, 36

selecting, 37

setting location, 125, 156

showing, 35, 157

Labeling, 75–77, 152

Lamp Wizard, 127–28, 149

Language, 147

License

key, 3, 148, 170

parking, 151, 155

transferring, 3, 160

viewing log, 161

Lines, 9–10, 170

appearance, 98

breaking, 106, 144

discontinuous, 106–7, 170

joining, 105–6, 149

moving, 36–37

properties, 42, 147, 149

pulling apart, 123–24

sections, 41, 170

selecting, 37

subdividing, 55–56

Menu bar, 22, 171

Moving, 114, 150

Multiple designs and views, 129–32

Nudging, 38, 151

Numbering, 75–77, 152

Offsetting, 151

Opening designs, 16, 151

Orientation, 26

Page Setup, 18, 24–26, 151

Panning, 32, 151

Pasting, 99, 152

Picking, 23, 152

Pieces, 12, 63, 74, 171

Plotting, 152

Polygons, 51, 152

Precision, 23–24, 160

Printer calibration, 26

Printing, 18, 27–28, 153

options, 24–26

preview, 27, 153

Properties of a design, 78–82, 153

Purchasing, 153

Rectangles, 47–48, 154

Redo, 154

Reflecting, 117–19, 154

Registration number, 148

Repeating, 154

Resizing, 17, 111–12, 155

RGB color model, 166–67

Rotating, 112–13, 155
Rulers, 34, 157, 171
Saving designs, 45, 155
Scaling, 114–15, 155
Scanning, 87
Scroll bars, 22
Scrolling, 32
Selecting, 37, 155, 156, 160
Selection color, 98
Sending designs via email, 89, 156
Shortcut menu, 46, 51–53, 171
Showing
  colors, 35, 157
  crosshairs, 157
  grid lines, 95, 157
  hairlines, 34, 42, 98, 157
  knots, 35, 157
  rulers, 34, 157
Sliders, 10–11, 44, 171
Snapping to the grid, 96, 144, 158
Squares, 47–48, 158
Status bar, 22, 158, 172
Sticky, 43, 159
Straight lines, 12
Straighten, 126, 159
Stretch box, 109, 172
Stretching, 109, 159
Subdividing line sections, 55–56, 159
Suggest, 58–62, 159
System requirements, 2
Technical support, 8
Text, 74–77
  adding, 74, 143
  editing, 75, 147
  setting the font, 75, 156
Title bar, 22, 172
Toolbar, 160, 172
Tutorial, 160
Undo, 39, 160
Ungrouping, 124, 160
Uninstalling, 2
Units, 23–24, 160
Updates, 62, 147
Vertical lines, 105, 115
View properties, 34–35, 97–98, 161
Views, 172
  creating, 150
  redrawing, 154
What’s This?, 29, 161
Windows
  closing, 22, 145
  moving, 150
  sizing, 22, 150, 155
Working color, 40, 172
Yanking, 123–24, 161
Zooming, 33, 161, 162